707 HP displayed

Discussion in 'Dodge Charger SRT Hellcat' started by GhostHellcat, Aug 11, 2015.

  1. GhostHellcat

    GhostHellcat Hellcat Member

    Joined:
    Jun 30, 2015
    Messages:
    31
    Likes Received:
    4
    Trophy Points:
    8
    Location:
    Va
    Vehicle:
    Charger SRT Hellcat
    Guys saw something new the tis w/e while driving around on Sunday. Left house with RED Key and was driving around in Default Mode, stopped at friends house shut it down for few minutes and then remote started it to give buddy Incenetive Ride. Pulled away and 707HP was showing but it was truly not performing in the 707 Mode. Drove it back to his house , shut down and re-started and True 707 was there.

    Has anybody scene or heard of this ?
     
  2. hellcat1

    hellcat1 Gold Member

    Joined:
    Sep 27, 2014
    Messages:
    10,668
    Likes Received:
    2,026
    Trophy Points:
    778
    Location:
    Michigan
    Vehicle:
    Challenger SRT Hellcat
    Your talking about in the pervading
    Performance pages..I haven't seen more then 692
     
  3. GhostHellcat

    GhostHellcat Hellcat Member

    Joined:
    Jun 30, 2015
    Messages:
    31
    Likes Received:
    4
    Trophy Points:
    8
    Location:
    Va
    Vehicle:
    Charger SRT Hellcat
    No sorry, Car acted like it was running with Black Installed or Valet Mode activated.
     
  4. B5 Blue

    B5 Blue Platinum Member

    Joined:
    Jan 5, 2015
    Messages:
    6,857
    Likes Received:
    1,742
    Trophy Points:
    1,178
    Location:
    Michigan
    Vehicle:
    Charger SRT Hellcat
    After I made a pass on the return road mine showed it went to 500 horse:mad:
     
  5. GhostHellcat

    GhostHellcat Hellcat Member

    Joined:
    Jun 30, 2015
    Messages:
    31
    Likes Received:
    4
    Trophy Points:
    8
    Location:
    Va
    Vehicle:
    Charger SRT Hellcat
    I could not even light up my tires.
     
  6. B5 Blue

    B5 Blue Platinum Member

    Joined:
    Jan 5, 2015
    Messages:
    6,857
    Likes Received:
    1,742
    Trophy Points:
    1,178
    Location:
    Michigan
    Vehicle:
    Charger SRT Hellcat
    I believe it. My traction set to sport decides to not spin tires for burnout like in street so I have to put in track mode all while trying to heat the meat
     
  7. hellcat1

    hellcat1 Gold Member

    Joined:
    Sep 27, 2014
    Messages:
    10,668
    Likes Received:
    2,026
    Trophy Points:
    778
    Location:
    Michigan
    Vehicle:
    Challenger SRT Hellcat
    Sounds like a software problem..
     
  8. Carnage

    Carnage SRT Hellcat Supercharged Moderator Staff Member Hellcat Car Club Gold Supporting Member HCC Charter Member

    Joined:
    Sep 21, 2014
    Messages:
    12,108
    Likes Received:
    3,265
    Trophy Points:
    823
    Location:
    Houston, TX
    Vehicle:
    Challenger SRT Hellcat
    Uh oh done the uconnect update? If not sensor might be broken or something. Or they sold a fake hellcat :p
     
    • Funny Funny x 1

Share This Page

Search tags for this page

707 hellcat poster

,

tis hell cat