Battery Light...

Discussion in 'SRT Hellcat General Discussions' started by fflundy, Mar 11, 2015.

  1. fflundy

    fflundy Gold Member

    Joined:
    Dec 4, 2014
    Messages:
    645
    Likes Received:
    335
    Trophy Points:
    313
    Location:
    Minneapolis, MN
    Vehicle:
    Challenger SRT Hellcat
    Going to have to take the Hellcat into the shop at 908 miles. Had an issue 3 times now after coming out from driving for a while. Push start button and it goes through it's gyrations, and does not start. push button to off, open door, try again several times, then starts out of nowhere. 2nd time it happened, I started with remote. Now after third time, Battery light is on. Has remained on, through the last three driving cycles.
    Anyone have similar?? I seem to remember a thread about a connection without proper gel coating. wonder if that could be a lead...
    Thanks!
    Jim
     
  2. rayzazoo

    rayzazoo DRIVESRT.COM Gold Supporting Member

    Joined:
    Nov 8, 2014
    Messages:
    2,998
    Likes Received:
    1,096
    Trophy Points:
    668
    Vehicle:
    Challenger SRT Hellcat
    You need to get a code reader hooked up to it.
     
    • Useful Useful x 1
  3. Tammie

    Tammie SRT Hellcat Moderator Staff Member Gold Supporting Member

    Joined:
    Sep 11, 2014
    Messages:
    13,474
    Likes Received:
    4,534
    Trophy Points:
    1,223
    Location:
    Washington
    Vehicle:
    Challenger SRT Hellcat
    You have checked your battery cables for good connection? I would check and get to the shop.
     
    • Agree Agree x 1
    • Useful Useful x 1
  4. RadCat

    RadCat Left Shark

    Joined:
    Nov 3, 2014
    Messages:
    1,141
    Likes Received:
    310
    Trophy Points:
    218
    Location:
    Oklahoma
    Vehicle:
    Challenger SRT Hellcat
    Yes, it might be something as simple as a loose battery cable..or a bad alternator....
     
    • Like Like x 1
  5. fnkychkn

    fnkychkn swollen member Gold Supporting Member

    Joined:
    Jan 24, 2015
    Messages:
    1,371
    Likes Received:
    486
    Trophy Points:
    368
    Location:
    plastic take-out container
    Vehicle:
    Charger SRT Hellcat
    found a few similar cases in online database. all point to IBS (intelligent battery sensor) issues.
    most common issue pertains to improper disconnect procedure and installation torque:
     

    Attached Files:

    • Useful Useful x 1

Share This Page