Can't pair my phone. Little things are so frustrating.

Discussion in 'Dodge Challenger SRT Hellcat' started by Hubbs, Jul 13, 2015.

  1. Hubbs

    Hubbs Silver Member

    Joined:
    Nov 17, 2014
    Messages:
    701
    Likes Received:
    154
    Trophy Points:
    153
    Location:
    McKinney, TX
    Vehicle:
    Challenger SRT Hellcat
    I've got an Samsung Note 3 and it won't talk to my HC. It worked fine in my 2013 SRT8 and works fine in my 2013 Ram. I recently had to exchange my phone under warranty and got a replacement, but it's no different.

    SRT says it's listed as a phone that should work, but they can't figure out what's wrong. Any ideas?
     
    Last edited: Jul 15, 2015
  2. B5 Blue

    B5 Blue Platinum Member

    Joined:
    Jan 5, 2015
    Messages:
    6,857
    Likes Received:
    1,742
    Trophy Points:
    1,178
    Location:
    Michigan
    Vehicle:
    Charger SRT Hellcat
    So you have phone seeking Bluetooth devices and nothing while the car is searching?
     
  3. Hubbs

    Hubbs Silver Member

    Joined:
    Nov 17, 2014
    Messages:
    701
    Likes Received:
    154
    Trophy Points:
    153
    Location:
    McKinney, TX
    Vehicle:
    Challenger SRT Hellcat
    Nothing. The last Note 3 I had would see the Uconnect, but I would get an error "cannot communicate with Uconnect".

    This new Note 3 doesn't see it at all. The response is "no bluetooth devices found".

    I've tried making the phone "visible" to other devices (not required for pairing, but worth a try). No help.

    I've rebooted everything and tried every which way I can think of over the last few months. No luck.
     
  4. MaxxMuscle

    MaxxMuscle Gold Member Hellcat Car Club HCC Charter Member

    Joined:
    Feb 10, 2015
    Messages:
    691
    Likes Received:
    274
    Trophy Points:
    213
    Location:
    Lafayette La.
    Vehicle:
    Challenger SRT Hellcat
    I have a Note 3 and mine works fine.Wish I would have watched how my salesman connected before leaving with my car .:(
     
  5. purnrg

    purnrg BANNED

    Joined:
    Apr 12, 2015
    Messages:
    2,619
    Likes Received:
    1,154
    Trophy Points:
    588
    Vehicle:
    Challenger SRT Hellcat
    Go into the phone settings and Make it visible to all, start pairing on UConnect, make sure the phone can see the Uconnect (it may show up as headset first), pick that from the phone, should work fine, I have had to change the Bluetooth connection method on advanced settings sometimes though.

    Does your phone see and pair with other Bluetooth devices okay?
     
  6. B5 Blue

    B5 Blue Platinum Member

    Joined:
    Jan 5, 2015
    Messages:
    6,857
    Likes Received:
    1,742
    Trophy Points:
    1,178
    Location:
    Michigan
    Vehicle:
    Charger SRT Hellcat
    So you disconnected hot all the time (30 circuit) at or to the radio so it went dead? Can someone else bond their phone to the HC?
     
  7. 70Cuda

    70Cuda Yep, its got a HEMI

    Joined:
    Oct 19, 2014
    Messages:
    4,771
    Likes Received:
    1,766
    Trophy Points:
    778
    Location:
    Wisconsin, USA
    Vehicle:
    Challenger SRT Hellcat
    Was even better on the 15 than my 12, should work really easy.

    there has to be a setting on your phone turned off.
     
  8. CubeMan

    CubeMan Tri-State Overlord

    Joined:
    Dec 31, 2014
    Messages:
    1,950
    Likes Received:
    468
    Trophy Points:
    403
    Location:
    Westchester
    Vehicle:
    Challenger SRT Hellcat
    can you bluetooth your phone to anything else (In-house stereo or etc?). You can go to your dealership and they will help you also.

    Make sure bluetooth is enabled on your phone
    Go to phone on your car and it'll ask if you want to pair a phone, hit yes then it'll tell you to look for Uconnect on your phone's bluetooth menu/list. Tap that and it'll ask you if the numbers match whats on your Radio/NAV screen, hit yes. You are pair'd now
     
  9. solo7777

    solo7777 SRT Terminator Hellcat Car Club Western Regional President HCC Charter Member

    Joined:
    Nov 25, 2014
    Messages:
    3,045
    Likes Received:
    1,368
    Trophy Points:
    768
    Location:
    City Of The Angels
    Vehicle:
    Challenger SRT Hellcat
    Do you have the latest version of U Connect installed? Not that it should matter, but you never know. Also, if you haven't already, make sure there are no other devices previously paired. I think there is a list and you can delete all previous BT devices.
     
  10. Hubbs

    Hubbs Silver Member

    Joined:
    Nov 17, 2014
    Messages:
    701
    Likes Received:
    154
    Trophy Points:
    153
    Location:
    McKinney, TX
    Vehicle:
    Challenger SRT Hellcat
    Done that several times. It won't even see Uconnect. It says "no bluetooth devices detected".

    The phone works just fine with my 2013 Ram.
     
  11. Hubbs

    Hubbs Silver Member

    Joined:
    Nov 17, 2014
    Messages:
    701
    Likes Received:
    154
    Trophy Points:
    153
    Location:
    McKinney, TX
    Vehicle:
    Challenger SRT Hellcat
    No, I pulled the battery for 2 minutes, then reconnected.
     
  12. Hubbs

    Hubbs Silver Member

    Joined:
    Nov 17, 2014
    Messages:
    701
    Likes Received:
    154
    Trophy Points:
    153
    Location:
    McKinney, TX
    Vehicle:
    Challenger SRT Hellcat
    The bottom line is, I know how to pair the phone and it works really easily in my Ram. Obviously it's not a problem with the phone.

    I may go by the dealer with it. I called Uconnect and they couldn't figure it out though.
     
  13. B5 Blue

    B5 Blue Platinum Member

    Joined:
    Jan 5, 2015
    Messages:
    6,857
    Likes Received:
    1,742
    Trophy Points:
    1,178
    Location:
    Michigan
    Vehicle:
    Charger SRT Hellcat
    Try Disconnect battery cables at battery turn headlight switch on then hold the cables together 60 seconds then reconnect
     
  14. purnrg

    purnrg BANNED

    Joined:
    Apr 12, 2015
    Messages:
    2,619
    Likes Received:
    1,154
    Trophy Points:
    588
    Vehicle:
    Challenger SRT Hellcat
    Try pairing a different phone, maybe the BT in the car isnot active or bad?
     
    • Agree Agree x 2
  15. Hubbs

    Hubbs Silver Member

    Joined:
    Nov 17, 2014
    Messages:
    701
    Likes Received:
    154
    Trophy Points:
    153
    Location:
    McKinney, TX
    Vehicle:
    Challenger SRT Hellcat
    Thanks guys. I think I'll try the hard reset of the car one more time just to rule it out plus I'll make sure the wife's phone pairs ok. If her's doesn't either I think I'll know for sure the bluetoof is bad.
     
    • Like Like x 1

Share This Page

Search tags for this page

make uconnect visible to phone