Downshift

Discussion in 'New Member Introduction' started by Livewire, Aug 7, 2015.

  1. Livewire

    Livewire Rookie

    Joined:
    Aug 4, 2015
    Messages:
    5
    Likes Received:
    3
    Trophy Points:
    3
    Vehicle:
    Challenger SRT Hellcat
    I just picked up my hellcat last week. I have driven it about 120 miles, first 90 from the dealership home. I noticed a few times that when I try to shift into 2nd, it grinds when I let off the clutch and is not fully engaged. Today I noticed that when I downshift into 2nd, it again grinds and is not fully engaged. I thought it was the skip shift, but it does it at 30 mph which is above what the manual says are the parameters of the skip shift. Anyone else have this issue?
     
  2. 4510

    4510 SRT Hellcat Supporter Gold Supporting Member

    Joined:
    May 13, 2015
    Messages:
    722
    Likes Received:
    158
    Trophy Points:
    153
    Location:
    Arizona
    Vehicle:
    Challenger SRT Hellcat
    I have a skip shift eliminator so I never see that function activate. I get no grinding going into or out of any gear.
    What you are describing seems abnormal. I'd head to the dealer and warranty.
     
  3. april77

    april77 Naughty SheDevil Mod Staff Member Hellcat Car Club Gold Supporting Member HCC Charter Member

    Joined:
    Dec 23, 2014
    Messages:
    6,443
    Likes Received:
    3,609
    Trophy Points:
    963
    Location:
    South Georgia, USA
    Vehicle:
    Challenger SRT Hellcat
    Hello, and welcome to the forum! Grtz on the HellCat! To address your question, my Cat is an A8, so I am not helpful. As 4510 above said, might want to head to the dealer. Let us know how it turns out, please.

    April
     

Share This Page