Drive mode

Discussion in 'Dodge Challenger SRT 392' started by Boggs, Feb 21, 2016.

  1. Boggs

    Boggs Senior Hellcat Member

    Joined:
    Feb 20, 2016
    Messages:
    132
    Likes Received:
    21
    Trophy Points:
    48
    Vehicle:
    Challenger SRT 392
    I'm trying to figure out on my SRT 392 2016 challenger what drive mode put the most horse power to the pavement is track with traction totally off or just track mode and when I'm driving and I hit the SRT button and switch drive mode while I have performance pages on egine it locks me out from going back to performance pages thanks in advance not really up to going back to dealer
     
  2. go fast chuck

    go fast chuck Hellcat Member

    Joined:
    Nov 8, 2015
    Messages:
    44
    Likes Received:
    19
    Trophy Points:
    8
    Location:
    kc
    Vehicle:
    Challenger SRT Hellcat
    I know this is the SRT area but my 16 a8 Challenger HC. did this today also and for the second or possible third time, Performance pages was still highlighted in red but would not come back to the screen. This was after making several changes back and forth to different default,sport and track settings on the fly during some spirited driving. I was showing off the car to some friends on their heart pumping initiation ride. We all wanted to see the different readings using the various gauges. It worked again a few hours later for the trip home .

    Has anybody else had this happen is it a software problem?
    Does Performance Pages need to be closed to switch drive-ability settings and restarted after or what?
    Any enlightenment on this would be very much appreciated its frustrating not having gauges, power and gear info at a quick glance without shutting the car down and waiting to get a reset.
     
  3. go fast chuck

    go fast chuck Hellcat Member

    Joined:
    Nov 8, 2015
    Messages:
    44
    Likes Received:
    19
    Trophy Points:
    8
    Location:
    kc
    Vehicle:
    Challenger SRT Hellcat
    Come on anybody out there to help sort this out?
    Still frustrated thanks!!!
     
  4. Boggs

    Boggs Senior Hellcat Member

    Joined:
    Feb 20, 2016
    Messages:
    132
    Likes Received:
    21
    Trophy Points:
    48
    Vehicle:
    Challenger SRT 392
    I haven't driven my car did you try to turn off performance pages and then switch drive mode
     
  5. BULL

    BULL ________173.7mph_______ ___2016 Colorado Mile___ Gold Supporting Member

    Joined:
    Nov 20, 2014
    Messages:
    1,953
    Likes Received:
    608
    Trophy Points:
    458
    Location:
    Colorado
    Vehicle:
    Challenger SRT Hellcat
    I've only noted slow access on occasion, but never have I been locked out.

    It's a shyt answer, but I suppose it's like any other computer you've ever used, it occasionally need to be kicked in the sack and rebooted... :mad:
     
    • Funny Funny x 1
  6. go fast chuck

    go fast chuck Hellcat Member

    Joined:
    Nov 8, 2015
    Messages:
    44
    Likes Received:
    19
    Trophy Points:
    8
    Location:
    kc
    Vehicle:
    Challenger SRT Hellcat
    Drive modes work fine its the Performance pages that is the problem locking up and not coming back until after a shutdown and several minute wait. Also an error message stating performance pages are not available while car is in motion when car is stopped and in park. What good is having gauges if they will not work while driving?
     
    Last edited: Feb 22, 2016
  7. Boggs

    Boggs Senior Hellcat Member

    Joined:
    Feb 20, 2016
    Messages:
    132
    Likes Received:
    21
    Trophy Points:
    48
    Vehicle:
    Challenger SRT 392
    Mine is just locking me out when I switch drive mode while driving app stays red on dash and won't reboot unless I shut car down to reset
     
  8. go fast chuck

    go fast chuck Hellcat Member

    Joined:
    Nov 8, 2015
    Messages:
    44
    Likes Received:
    19
    Trophy Points:
    8
    Location:
    kc
    Vehicle:
    Challenger SRT Hellcat
    Yes exactly
     
  9. Boggs

    Boggs Senior Hellcat Member

    Joined:
    Feb 20, 2016
    Messages:
    132
    Likes Received:
    21
    Trophy Points:
    48
    Vehicle:
    Challenger SRT 392
    If it keeps doing it I'll bring it back to dealer it only has 527 miles maybe something needs an update
     
  10. go fast chuck

    go fast chuck Hellcat Member

    Joined:
    Nov 8, 2015
    Messages:
    44
    Likes Received:
    19
    Trophy Points:
    8
    Location:
    kc
    Vehicle:
    Challenger SRT Hellcat
    Mine has 787 miles now and they just checked all the updates at about 700 miles less than a month ago when they replaced the evap. purge valve it was sticking in the cold and setting a code. I am not wanting to make another trip back this soon either but it could use a tire rotation I sure haven't been very nice to them of late.
     
  11. SublimeSRT

    SublimeSRT Rookie

    Joined:
    Jun 13, 2015
    Messages:
    12
    Likes Received:
    4
    Trophy Points:
    3
    Location:
    West Hartford, CT
    Vehicle:
    Challenger SRT 392
    This has also happened to me, but only once.
     

Share This Page