Engine shuts off while driving!!!!!

Discussion in 'Dodge Charger SRT 392' started by xSoLD3Rv, Dec 24, 2015.

  1. xSoLD3Rv

    xSoLD3Rv Rookie

    Joined:
    Dec 24, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Vehicle:
    Charger SRT 392
    Hey guys,
    I have received my Charger SRT 392 yesterday and i really love it :D
    But i have faced a weird issue, while i am in low speed (riding over a speed hump) the car just shuts off and i see a message that says (switch to park then start the engine). i follow the instructions and it runs again like a charm.
    i have faced this problem twice with the same conditions (low speed etc.)
    Any suggestions on what should i do?
     
    • Funny Funny x 1
  2. graycat

    graycat Automobile Aficionado Extraordinaire Staff Member

    Joined:
    Oct 1, 2015
    Messages:
    1,355
    Likes Received:
    522
    Trophy Points:
    193
    Location:
    Knoxville, TN
    Vehicle:
    Challenger SRT Hellcat
    Welcome to the forum!!!!!

    Sorry to hear that you are having this problem. I've not saw another person post such a problem
    but a guess, and it's just that, a guess, I'd say that you may have a loose or bad ground or connection somewhere.

    I'd be at the dealer as quickly as possible. It's not likely but definitely a possibility that you could
    end up with bigger issues if it's not fixed soon. Loose or poor connections CAN cause excessive
    heat which can lead to melted wires and insulation on those wires or even worse.

    Best of luck to you and Merry Christmas!!!!
     
  3. junglas

    junglas Hellcat Member

    Joined:
    Nov 27, 2015
    Messages:
    69
    Likes Received:
    16
    Trophy Points:
    8
    Location:
    Kuwait
    Vehicle:
    Charger SRT 392
    GO. TO. DEALER. ASAP. !!
     
  4. fnkychkn

    fnkychkn swollen member Gold Supporting Member

    Joined:
    Jan 24, 2015
    Messages:
    1,370
    Likes Received:
    486
    Trophy Points:
    368
    Location:
    plastic take-out container
    Vehicle:
    Charger SRT Hellcat
    Only does it over the same speed bump?
    Engine runtime from cold start the same both times?
    Possible bad fuel?
     
    • Useful Useful x 1
  5. Angel

    Angel Gold Member

    Joined:
    Aug 19, 2015
    Messages:
    1,208
    Likes Received:
    530
    Trophy Points:
    313
    Location:
    League City, TX
    Vehicle:
    Challenger SRT Hellcat
    Yes something is wrong so take it to the dealership because this is not normal. Please keep us informed.
     
  6. NorCaletch19He77Kat

    NorCaletch19He77Kat Silver Member

    Joined:
    Aug 30, 2015
    Messages:
    905
    Likes Received:
    270
    Trophy Points:
    173
    Vehicle:
    Challenger SRT Hellcat
    orobably a bad switch on the automatic shifter
     
  7. xSoLD3Rv

    xSoLD3Rv Rookie

    Joined:
    Dec 24, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Vehicle:
    Charger SRT 392
    no, it happened on two different locations.
    as for second question, i am assuming you are asking if the engine was warmed before driving? if so, then yes it was warmed
     
  8. xSoLD3Rv

    xSoLD3Rv Rookie

    Joined:
    Dec 24, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Vehicle:
    Charger SRT 392
    UPDATE:
    One more issue :(
    while i was driving at low speed, i noticed a message saying "Shift to P then Desired Gear", and the (D) sign was flashing both in the gear shifter and in the center display. i tried pressing gas, the car seems like it is on Neutral gear N and it revs only without moving. I moved the gear into N position, then back to D. and it starts driving again normally as if nothing happened!!:eek:

    I will check with the dealer ASAP and i will update you guys
     
  9. NorCaletch19He77Kat

    NorCaletch19He77Kat Silver Member

    Joined:
    Aug 30, 2015
    Messages:
    905
    Likes Received:
    270
    Trophy Points:
    173
    Vehicle:
    Challenger SRT Hellcat
    auto shifter issue--minor in nature--probably just an adjustment
     
  10. xSoLD3Rv

    xSoLD3Rv Rookie

    Joined:
    Dec 24, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Vehicle:
    Charger SRT 392
    UPDATE
    took it to the dealer yesterday, they took the car and i haven't received any news from them yet.
    Meanwhile they gave me Fiat 500 as a replacement car.
    Now all i can do is wait and use Fiat 500 instead of SRT :(

    [​IMG]
     
  11. SRT_HC_707

    SRT_HC_707 SRT_HC_707 Staff Member

    Joined:
    Jan 1, 2015
    Messages:
    4,920
    Likes Received:
    1,417
    Trophy Points:
    778
    Location:
    70.196059, -148.559760
    Vehicle:
    Challenger SRT Hellcat
    Giving you a Fiat 500 loaner is just plain WRONG! LOL
     
  12. junglas

    junglas Hellcat Member

    Joined:
    Nov 27, 2015
    Messages:
    69
    Likes Received:
    16
    Trophy Points:
    8
    Location:
    Kuwait
    Vehicle:
    Charger SRT 392
    Take it easy man, hopefully it will just be some minor fixes and nothing too serious. But I gotta give you a huge LOL on the Fiat. Let's not forget though Fiat did build / design half of this car, so...
     
  13. NorCaletch19He77Kat

    NorCaletch19He77Kat Silver Member

    Joined:
    Aug 30, 2015
    Messages:
    905
    Likes Received:
    270
    Trophy Points:
    173
    Vehicle:
    Challenger SRT Hellcat
    hey those Fiats are hot!!! think of the wear and tear you're not putting on your HellCat!!

    Drive that Fiat as if it's the end of the world!
     

Share This Page

Search tags for this page

2015-2016 dodge charger turns off while driving

,

2016 dodge challenger shuts off while driving

,

2016 dodge dart shuts off while driving why

,

dodge challenger turns off while driving

,

dodge dart shut off while driving

,

dodge ram shuts off while driving