Grinning/rubbing noise going uphill

Discussion in 'SRT Hellcat General Discussions' started by sgoyal, May 5, 2016.

  1. sgoyal

    sgoyal Gold Member

    Joined:
    Jul 10, 2015
    Messages:
    2,244
    Likes Received:
    794
    Trophy Points:
    458
    Location:
    Suwanee, Georgia
    Vehicle:
    Challenger SRT Hellcat
    We put a new aluminum driveshaft last week and had to use a hammer to make extra clearance. I notice grinding/rubbing noise going uphill today but otherwise there's no noise.

    Or could it be tire rubbing so hard? I can't see how tire rub because I see enough space between wheel liner and tire
     
  2. sgoyal

    sgoyal Gold Member

    Joined:
    Jul 10, 2015
    Messages:
    2,244
    Likes Received:
    794
    Trophy Points:
    458
    Location:
    Suwanee, Georgia
    Vehicle:
    Challenger SRT Hellcat
    Drive the car uphill again. If I go straight then no noise but if I move the car to little left or act like I'm making left turn then noise comes up. Gotta get under the car and put some tape and camera underneath.
     
  3. tsubahog

    tsubahog Gold Member

    Joined:
    Mar 30, 2015
    Messages:
    313
    Likes Received:
    154
    Trophy Points:
    293
    Location:
    NJ
    Vehicle:
    Challenger SRT Hellcat
    Sounds like the rear is flexing just enough for the DS to touch the inside of the tunnel. Had the same thing on my Sunbeam Tiger. Give it another whack!
     
    • Like Like x 1
  4. sgoyal

    sgoyal Gold Member

    Joined:
    Jul 10, 2015
    Messages:
    2,244
    Likes Received:
    794
    Trophy Points:
    458
    Location:
    Suwanee, Georgia
    Vehicle:
    Challenger SRT Hellcat
    We got underneath the car and thinking of having few more hammers in the hands. But we noticed damn wheel liner from both side were next to 305 Nitto.

    We put the Rivet and go for ride... so far no noise. I'd run some uphill and left/right turn again and see if we finally find the root cause or not.
     

Share This Page