Just a question about start up idling ?

Discussion in 'SRT Hellcat Maintenance' started by Hellcat 666, Oct 8, 2015.

  1. Hellcat 666

    Hellcat 666 Rookie

    Joined:
    Apr 22, 2015
    Messages:
    28
    Likes Received:
    10
    Trophy Points:
    3
    Vehicle:
    Challenger SRT Hellcat
    After a few months of driving the Hellcat around to 2500 miles on it now . When starting after letting it sit for a day or two it goes to normal idle for about 5-10 seconds then acts like it is dying for a few seconds then goes to a high idle for about 30 seconds and returns to normal . Is this due to colder weather ? or normal operating ? should I take it in for a check up ? I always let it warm up before driving it out of the garage .
     
  2. FreightTrain

    FreightTrain Comfortably Numb

    Joined:
    Sep 13, 2014
    Messages:
    3,511
    Likes Received:
    1,424
    Trophy Points:
    818
    Location:
    Endless Mtns of Pa
    Vehicle:
    Challenger SRT Hellcat
    doesnt sound normal.. mine goes to hi idle right away and lowers after 20-30 seconds (guessing) even in summer with a cold engine, a little longer when its actually really cold out..
     
  3. HCone

    HCone Gold Member

    Joined:
    Dec 4, 2014
    Messages:
    1,055
    Likes Received:
    303
    Trophy Points:
    218
    Location:
    upper center middle of no where
    Vehicle:
    Challenger SRT Hellcat
    same here
     
  4. Link

    Link Silver Member

    Joined:
    Jan 27, 2015
    Messages:
    796
    Likes Received:
    160
    Trophy Points:
    153
    Vehicle:
    Challenger SRT Hellcat
    same, about 1700 initially then drops down to about 700 in increments.
     
  5. TallCool1

    TallCool1 Gold Member Hellcat Car Club Gold Supporting Member Nat'l Hellcat Tech Advisor HCC Charter Member

    Joined:
    Jan 5, 2015
    Messages:
    2,392
    Likes Received:
    791
    Trophy Points:
    458
    Location:
    Pacific NW
    Vehicle:
    Challenger SRT Hellcat

Share This Page