Leak???

Discussion in 'SRT Hellcat Maintenance' started by petehellcst, Aug 14, 2015.

  1. petehellcst

    petehellcst Hellcat Member

    Joined:
    Jun 6, 2015
    Messages:
    41
    Likes Received:
    24
    Trophy Points:
    8
    Location:
    Abu Dhabi
    Vehicle:
    Charger SRT Hellcat
    Just spotted this while blowing the sand out of the engine bay. Looks like a leak, anyone know what this is or had this problem?

    image.jpg image.jpg
     
    • Useful Useful x 1
  2. B5 Blue

    B5 Blue Platinum Member

    Joined:
    Jan 5, 2015
    Messages:
    6,857
    Likes Received:
    1,742
    Trophy Points:
    1,178
    Location:
    Michigan
    Vehicle:
    Charger SRT Hellcat
    Normal
     
    • Like Like x 1
    • Agree Agree x 1
  3. Themip

    Themip Gold Member

    Joined:
    Nov 15, 2014
    Messages:
    507
    Likes Received:
    212
    Trophy Points:
    293
    Location:
    'Murica
    Vehicle:
    Charger SRT Hellcat
    yes mine had that as well
     
  4. Lord Hellcat

    Lord Hellcat Gold Member Hellcat Car Club Gold Supporting Member HCC UK President HCC Charter Member

    Joined:
    Jan 6, 2015
    Messages:
    1,496
    Likes Received:
    645
    Trophy Points:
    463
    Location:
    UK
    Vehicle:
    Challenger SRT Hellcat
    I had the same. I cleaned it all up and it has never leaked since. No cable ties just left it as it was
     
  5. petehellcst

    petehellcst Hellcat Member

    Joined:
    Jun 6, 2015
    Messages:
    41
    Likes Received:
    24
    Trophy Points:
    8
    Location:
    Abu Dhabi
    Vehicle:
    Charger SRT Hellcat
    Great news, i will clean it today.
    Thanks for your replies.
     
  6. Hb hellcat

    Hb hellcat Black Betty...BamAlam!!!

    Joined:
    Feb 14, 2015
    Messages:
    536
    Likes Received:
    166
    Trophy Points:
    153
    Location:
    Sunny Southern California
    Vehicle:
    Charger SRT Hellcat
    Mine had same seepage. I've cleaned about three times in first 600 miles(I'm a bit anal) and doesnt seem to be coming back. About 2100 miles now. Will check with dealer when goes in for first oil change this coming week.
     

Share This Page