My Hellcat Decides 700+ is Not Necessary

Discussion in 'SRT Hellcat General Discussions' started by VanishingPoint, Apr 8, 2015.

  1. VanishingPoint

    VanishingPoint Silver Member

    Joined:
    Jan 6, 2015
    Messages:
    917
    Likes Received:
    233
    Trophy Points:
    193
    Location:
    Somewhere, Texas
    Vehicle:
    Challenger SRT Hellcat
    My Hellcat Decides 700+ is Not Necessary...

    And periodically dials down to 500 in my CUSTOM settings.
    It has done this twice.
    I do not know why it does this.
    I have thrown the black keys in the ocean the day I got the car.
    It is bullshit though.

    That is all.
     
    • Funny Funny x 1
    • Useful Useful x 1
  2. StellasHC

    StellasHC Platinum Member

    Joined:
    Nov 18, 2014
    Messages:
    1,803
    Likes Received:
    1,274
    Trophy Points:
    933
    Location:
    Kenosha, Wisconsin
    Vehicle:
    Challenger SRT Hellcat

    Mine has done the same.. I was doing some "spirited" driving and was like "WTF, this thing is a Pooch!"... was going through the drive mode and saw the car was at 500hp.. and I know for a fact I was at 700hp when I started..
     
    • Like Like x 1
    • Useful Useful x 1
  3. B5 Blue

    B5 Blue Platinum Member

    Joined:
    Jan 5, 2015
    Messages:
    6,857
    Likes Received:
    1,742
    Trophy Points:
    1,178
    Location:
    Michigan
    Vehicle:
    Charger SRT Hellcat
    Hope it won't do that in the money rounds
     
    • Agree Agree x 1
  4. JohnnyHellcat

    JohnnyHellcat Gold Member

    Joined:
    Sep 20, 2014
    Messages:
    374
    Likes Received:
    474
    Trophy Points:
    513
    Location:
    West Palm Beach FL.
    Vehicle:
    Challenger SRT Hellcat
    Yes I have had that happen , and the worse place was at the dragstrip resulting in a 12 run! It happens every once in a while when the car is shut off ! Always double check your settings when on the track !
     
  5. Zebug

    Zebug Gold Member

    Joined:
    Nov 11, 2014
    Messages:
    2,596
    Likes Received:
    861
    Trophy Points:
    628
    Location:
    Houston Texas
    Vehicle:
    Challenger SRT Hellcat
    I don't even think my cat realizes it can dial it down....has been 700+ all day everyday. I'll have to keep an eye out for this, thanks for the intel.
     
    • Agree Agree x 2
  6. SRT_HC_707

    SRT_HC_707 SRT_HC_707 Staff Member

    Joined:
    Jan 1, 2015
    Messages:
    4,918
    Likes Received:
    1,415
    Trophy Points:
    778
    Location:
    70.196059, -148.559760
    Vehicle:
    Challenger SRT Hellcat
    Interesting. I wonder how you report that as a bug? Yet another Uconnect item that needs to be fixed.

    Is there a process for reporting bugs like this?

    Dodge should setup a public Bugzilla instance to report and track Uconnect bugs :D

    I haven't noticed this yet but I only have about 600 miles on the car and really haven't gotten on it at all. First 500 was break-in and the rest was just driving daily a few times. No good places for a good run yet.
     
  7. budkole

    budkole Best Color and fastest is undoubtedly WHITE

    Joined:
    Mar 14, 2015
    Messages:
    551
    Likes Received:
    188
    Trophy Points:
    193
    Location:
    St. Louis
    Vehicle:
    Charger SRT Hellcat
    Same here, never had a problem. Will keep an eye on it.
     
  8. Carnage

    Carnage SRT Hellcat Supercharged Moderator Staff Member Hellcat Car Club Gold Supporting Member HCC Charter Member

    Joined:
    Sep 21, 2014
    Messages:
    12,108
    Likes Received:
    3,265
    Trophy Points:
    823
    Location:
    Houston, TX
    Vehicle:
    Challenger SRT Hellcat
    i avoid any changes by setting everything in the default tab the way I want it so everytime the car powers on and I drive each time it stays the same instead of custom. Custom tab for some reason changes every time I turn off then power on the car. But with default it never changes and is the first profile it stays on each and everytime without fail.
     
    • Agree Agree x 1
  9. StellasHC

    StellasHC Platinum Member

    Joined:
    Nov 18, 2014
    Messages:
    1,803
    Likes Received:
    1,274
    Trophy Points:
    933
    Location:
    Kenosha, Wisconsin
    Vehicle:
    Challenger SRT Hellcat

    That is the problem with mine.. it backed down WHILE DRIVING. I set everything in my Custom setting when I started the car, drove it and pounded on it once and it backed down..weird
     
  10. Brett M

    Brett M Silver Member

    Joined:
    Oct 22, 2014
    Messages:
    539
    Likes Received:
    218
    Trophy Points:
    193
    Vehicle:
    Challenger SRT Hellcat
    Mine hasn't dialed down in HP, but the suspension and traction control will randomly change.
     
    • Agree Agree x 1
  11. Carnage

    Carnage SRT Hellcat Supercharged Moderator Staff Member Hellcat Car Club Gold Supporting Member HCC Charter Member

    Joined:
    Sep 21, 2014
    Messages:
    12,108
    Likes Received:
    3,265
    Trophy Points:
    823
    Location:
    Houston, TX
    Vehicle:
    Challenger SRT Hellcat
    Same here is also why I went default settings and made the changes there and been good since
     
  12. TallCool1

    TallCool1 Gold Member Hellcat Car Club Gold Supporting Member Nat'l Hellcat Tech Advisor HCC Charter Member

    Joined:
    Jan 5, 2015
    Messages:
    2,392
    Likes Received:
    791
    Trophy Points:
    458
    Location:
    Pacific NW
    Vehicle:
    Challenger SRT Hellcat
    imo that card is going to be played out fast hitting Tim K with everything. Opening cases with clear details with SRT would accomplish same.
     
    • Agree Agree x 2
    • Funny Funny x 1
    • Winner Winner x 1
  13. iya0yas

    iya0yas Silver Member

    Joined:
    Nov 10, 2014
    Messages:
    608
    Likes Received:
    149
    Trophy Points:
    153
    Location:
    Gastonia, North Carolina
    Vehicle:
    Challenger SRT Hellcat
    So for those of you who have experienced this issue are you driving the M6 or A8?
     
  14. Greg

    Greg Senior Hellcat Member Hellcat Car Club HCC Charter Member

    Joined:
    Mar 1, 2015
    Messages:
    59
    Likes Received:
    26
    Trophy Points:
    58
    Vehicle:
    Challenger SRT Hellcat
    I have experienced the issue twice that I have caught. Sets to 500 HP and the traction control or transmission (I forget which) goes to street. A8. The "extra fun" transmission and traction control settings can't be set on the default page.
     
  15. mopar sickness

    mopar sickness Silver Member

    Joined:
    Oct 2, 2014
    Messages:
    309
    Likes Received:
    102
    Trophy Points:
    153
    Location:
    Michigan
    Vehicle:
    Challenger SRT Hellcat
    I have had this happen on a Sunday cruise .nothing real extreme .went to settings to check things out and there it was 500hp.wtf red key in car and 700hp set the last time I had the car out.my vehicle is a January build with an A8
     

Share This Page