Navigation Problems - "Locking Up" WTF?

Discussion in 'SRT Hellcat Electronics' started by FLEX, Sep 1, 2015.

  1. FLEX

    FLEX Gold Member

    Joined:
    Apr 10, 2015
    Messages:
    425
    Likes Received:
    246
    Trophy Points:
    293
    Location:
    Mississauga, Ontario, Canada
    Vehicle:
    Charger SRT 392
    Took the new SRT for its first road trip last week to North Carolina.

    Nav worked perfectly the whole trip down and all week while driving around locally.

    On the way home it "locked up", so to speak. It still showed my location and all roads correctly but it stopped giving directions and all functionality froze. The time to destination and miles to next turn froze. It wouldn't respond to user inputs and would not recalculate the route.

    I pulled over and shut the car off and no change.

    When I got to the next rest stop I pulled everything out of the trunk and opened the fuse box and pulled the fuse to reset it. That worked. Temporarily.

    Got back on the road and it kept restarting the nav and eventually it froze again.

    Used my phone to navigate to the next stop then did the fuse pull again and same thing; it worked for a bit but kept restarting itself then finally froze.

    Stopped overnight and didn't even bother doing the fuse pull but the next day when I started the car it was working again. Worked fine for 90 minutes then froze again.

    Any ideas?
     
  2. stephenlocke

    stephenlocke Hellcat Member

    Joined:
    Apr 19, 2015
    Messages:
    51
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    CA -Bay Area
    Vehicle:
    Challenger SRT Hellcat
    Hats to say it but this is a gremlin I have in my 2009 ram with nav. Seems to happen when you enter a destination. Then make several stops. It then just stops telling you the next turn.
    next day everything works fine again
    mentioned issue to service folks. No route cause found.....
     
  3. Blown7

    Blown7 Hellcat Member

    Joined:
    Mar 6, 2015
    Messages:
    74
    Likes Received:
    14
    Trophy Points:
    8
    Vehicle:
    Charger SRT 392
    Seems that other sites/vehicles with the Nav/Uconnect are having problems
     
  4. dodgeboy

    dodgeboy Silver Member

    Joined:
    Dec 31, 2014
    Messages:
    344
    Likes Received:
    113
    Trophy Points:
    153
    Location:
    Michigan
    Vehicle:
    Charger SRT Hellcat
    This just started happening to mine two days ago! Mine will restart 5 or 6 times (just the nav portion of the screen) and then eventually freeze up until I restart the car. It restarts every 5-10 minutes until it locks up. I've driven the car 3 times for more than 50 miles since Monday, and it happened every time. I use the map a lot for traffic information (with no route entered), so I'm pretty confident it just started on monday and hasn't been happening since I updated it a month ago... but it is possible (unlikely) that it started after the update and I haven't noticed it. Nothing else with the car has changed that would've caused this. I was considering doing a hard reset on the thing, but now seeing as you are having the same problem, maybe I'll wait to see if it's affecting more people.

    I should also mention that I used it extensively during a 2500mi road trip back in April. There's no way there was even a hint of this issue back then, or it would've driven me crazy. The only issue I had during that entire trip is that the voice announcements would stop working after a couple hours and I'd have to restart the car to get them back. The interface never reset or locked up one time.

    Are you running the latest software? The one that came out in mid July, to address the hack issue? I am.
     
  5. gts_2001

    gts_2001 Gold Member

    Joined:
    Dec 7, 2014
    Messages:
    1,329
    Likes Received:
    391
    Trophy Points:
    358
    Location:
    Grand Rapids, MI
    Vehicle:
    Challenger SRT Hellcat
    I did the update on my Hellcat, 2014 RAM and 2014 Jeep Grand Cherokee about a month ago. While heading to Road America on Monday, I had the exact same experience with freezes, black screen, etc. Fortunately, I had my phone to get me back on track. I hope FCA fixes this soon! (BTW, while at Road America SRT Track Experience, many other participants voiced the same experience. Not Good!!)
     
  6. goat1964-2004

    goat1964-2004 Silver Member Hellcat Car Club HCC Charter Member

    Joined:
    Sep 26, 2014
    Messages:
    101
    Likes Received:
    75
    Trophy Points:
    168
    Location:
    Clifton Springs, NY
    Vehicle:
    Challenger SRT Hellcat
    My 2015 Durango R/T is also having this issue. Just started last week.
     
  7. dodgeboy

    dodgeboy Silver Member

    Joined:
    Dec 31, 2014
    Messages:
    344
    Likes Received:
    113
    Trophy Points:
    153
    Location:
    Michigan
    Vehicle:
    Charger SRT Hellcat
    Oddly enough, my issues seem to have completely gone away. Used the nav for over 2 hours today (both for navigation and just for referencing the map). It never acted up once. A few weeks ago it wouldn't have lasted 10 minutes without locking up and restarting. I don't get it.
     
  8. fnkychkn

    fnkychkn swollen member Gold Supporting Member

    Joined:
    Jan 24, 2015
    Messages:
    1,372
    Likes Received:
    486
    Trophy Points:
    368
    Location:
    plastic take-out container
    Vehicle:
    Charger SRT Hellcat
    posted on techconnect on sept 7th:

    • RA4 and RHR customers may report experiencing intermittent navigation resets. Specifically the map screen will go black while on the navigation screen and after a few seconds the radio will reboot and come back on in the navigation screen displaying navigation is being activated.

    • If the condition is consistent with the above, “Do Not Replace The Radio” exchange or replacement radios as it will not correct the concern. Engineering is working on a resolution that appears to be related to SXM weather APP and the recent tropical storm monitoring.

    • If a radio has been ordered for this. Please cancel the order and notify the customer engineering is working on a fix. This applies to all Chrysler and Fiat vehicles using RA4 and RHR Radios.
     
    • Winner Winner x 1
  9. rubbel

    rubbel Gold Member

    Joined:
    Jan 28, 2015
    Messages:
    167
    Likes Received:
    86
    Trophy Points:
    278
    Location:
    Wimauma, FL
    Vehicle:
    Charger SRT Hellcat
  10. dodgeboy

    dodgeboy Silver Member

    Joined:
    Dec 31, 2014
    Messages:
    344
    Likes Received:
    113
    Trophy Points:
    153
    Location:
    Michigan
    Vehicle:
    Charger SRT Hellcat
    Thanks! That explains it.
     

Share This Page

Search tags for this page

2011 dodge challenger stereo navigation problems

,

2014 charger rt navigation stopped working

,

radio locked on hellcat

,

ram 1500 navigation locked up