New One ...

Discussion in 'SRT Hellcat TSB's' started by Kado, Dec 25, 2015.

  1. Kado

    Kado Silver Member

    Joined:
    Dec 8, 2014
    Messages:
    141
    Likes Received:
    62
    Trophy Points:
    178
    Vehicle:
    Challenger SRT Hellcat
    Had this pop up after 400 miles....
     

    Attached Files:

    • Useful Useful x 1
  2. solo7777

    solo7777 SRT Terminator Hellcat Car Club Western Regional President HCC Charter Member

    Joined:
    Nov 25, 2014
    Messages:
    3,034
    Likes Received:
    1,368
    Trophy Points:
    768
    Location:
    City Of The Angels
    Vehicle:
    Challenger SRT Hellcat
    Did it go into limp home mode?
     
  3. bolivarshagnasty

    bolivarshagnasty Gold Member

    Joined:
    Oct 24, 2014
    Messages:
    1,580
    Likes Received:
    503
    Trophy Points:
    423
    Location:
    Chattanooga, Tennessee
    Vehicle:
    Challenger SRT Hellcat
    Barometric pressure sensor? Haven't heard of that one before. Hopefully the Dealer can get one ASAP. Good luck.
     
  4. Kado

    Kado Silver Member

    Joined:
    Dec 8, 2014
    Messages:
    141
    Likes Received:
    62
    Trophy Points:
    178
    Vehicle:
    Challenger SRT Hellcat
    Yep it went to limp mode. Cleared the code and 700 miles it hasn't come back
     
  5. 1FSTCAT

    1FSTCAT The Punisher

    Joined:
    Dec 28, 2014
    Messages:
    1,130
    Likes Received:
    407
    Trophy Points:
    358
    Location:
    Virginia
    Vehicle:
    Challenger SRT Hellcat
    Had one in a Ram 1500 go bad...it under the seat on the passenger side. I didn't even know it, they picked it up on a scheduled maintenance.
     

Share This Page

Search tags for this page

hellcat challenger limp mode