Not enough power

Discussion in 'SRT Hellcat General Discussions' started by Tweaked, May 24, 2015.

  1. Tweaked

    Tweaked Hellcat Member

    Joined:
    Mar 28, 2015
    Messages:
    93
    Likes Received:
    30
    Trophy Points:
    18
    Vehicle:
    Charger SRT Hellcat
    Have 3200 miles on car. Had setting at H.P. at 700 plus transmission set to track,paddle shifters on, traction sport and suspension to sport. I floored the car for the firsy time and my engine power indicator only showed 485 to 500. Why so low, second try boost showed 9. To me that is also low. Would traction control somehow limit the power I'm seeing?
     
  2. budkole

    budkole Best Color and fastest is undoubtedly WHITE

    Joined:
    Mar 14, 2015
    Messages:
    551
    Likes Received:
    188
    Trophy Points:
    193
    Location:
    St. Louis
    Vehicle:
    Charger SRT Hellcat
    Ive never looked at the power indicator, I will have to check that out. When you floored it, had it been running/driving for a while prior? Im no expert by any means, but wonder if heat soaking played a roll.
     
  3. huggytree

    huggytree Gold Member

    Joined:
    Nov 22, 2014
    Messages:
    3,086
    Likes Received:
    729
    Trophy Points:
    458
    Vehicle:
    Challenger SRT Hellcat
    do a 0-60 with the timer....what are you getting?
     
  4. Cerino2000

    Cerino2000 Gold Member

    Joined:
    Nov 8, 2014
    Messages:
    474
    Likes Received:
    126
    Trophy Points:
    293
    Vehicle:
    Challenger SRT Hellcat
    Did you let it wind out? You won't see the big numbers until the top of the rpm range.
     
    • Agree Agree x 1
  5. Tweaked

    Tweaked Hellcat Member

    Joined:
    Mar 28, 2015
    Messages:
    93
    Likes Received:
    30
    Trophy Points:
    18
    Vehicle:
    Charger SRT Hellcat
    Had transmission in drive car was shifting on its on. Pull was from 35 to about 90. I had driven the car about 45 miles prior to this. I dont know if heat soak was part of the problem or not. Next time out i will do a 0 to 60 time. I'm pretty sure the car was winding out. Just thought I would see better numbers. Does the boost sound about right?
     
  6. Harley88

    Harley88 Gold Member

    Joined:
    Nov 15, 2014
    Messages:
    1,217
    Likes Received:
    344
    Trophy Points:
    218
    Vehicle:
    Challenger SRT Hellcat
    Black key?
     
  7. Tweaked

    Tweaked Hellcat Member

    Joined:
    Mar 28, 2015
    Messages:
    93
    Likes Received:
    30
    Trophy Points:
    18
    Vehicle:
    Charger SRT Hellcat
    No black key allowed in this car.
     
    • Winner Winner x 3
  8. sahak

    sahak Silver Member

    Joined:
    Jan 17, 2015
    Messages:
    269
    Likes Received:
    70
    Trophy Points:
    138
    Vehicle:
    Challenger SRT Hellcat
    It could be the traction control not letting full power go to the tires so you don't spin out or it could be heat soaked
     
  9. WNY Cat

    WNY Cat SRT Hellcat Supporter Gold Supporting Member

    Joined:
    Nov 16, 2014
    Messages:
    563
    Likes Received:
    357
    Trophy Points:
    513
    Vehicle:
    Challenger SRT Hellcat
    You had 3200 miles on the car the first time you floored it?:eek: I should have given you my Hellcat to break it in properly. I think I had 25 miles on mine the first time I floored it.:confused:
     
    • Like Like x 4
    • Funny Funny x 2
  10. hellcat1

    hellcat1 Gold Member

    Joined:
    Sep 27, 2014
    Messages:
    10,668
    Likes Received:
    2,026
    Trophy Points:
    778
    Location:
    Michigan
    Vehicle:
    Challenger SRT Hellcat
    I played with mine today on the freeway and I seen numbers around 690,, btw I was toying with a z06...and a Shelby
     
  11. B5 Blue

    B5 Blue Platinum Member

    Joined:
    Jan 5, 2015
    Messages:
    6,857
    Likes Received:
    1,742
    Trophy Points:
    1,178
    Location:
    Michigan
    Vehicle:
    Charger SRT Hellcat
    Look at you:):)
     
    • Like Like x 1
  12. Robert7

    Robert7 Silver Member

    Joined:
    Dec 20, 2014
    Messages:
    133
    Likes Received:
    52
    Trophy Points:
    178
    Location:
    Washington
    Vehicle:
    Charger SRT Hellcat
    This problem made me think of this thread My Hellcat Decides 700 is Not Necessary SRT Hellcat Forum

    Does it help to try what CO Springs Sublime Kitty suggests, ie no custom settings?
     
    • Like Like x 1
  13. hellcat1

    hellcat1 Gold Member

    Joined:
    Sep 27, 2014
    Messages:
    10,668
    Likes Received:
    2,026
    Trophy Points:
    778
    Location:
    Michigan
    Vehicle:
    Challenger SRT Hellcat
    500 miles today......;)
     
    • Funny Funny x 1
  14. Tweaked

    Tweaked Hellcat Member

    Joined:
    Mar 28, 2015
    Messages:
    93
    Likes Received:
    30
    Trophy Points:
    18
    Vehicle:
    Charger SRT Hellcat
    Thank you Robert7 this was some good information, as I was in custom settings at the time. Funny thing is when I looked it still showed car in 700 plus mode.
     
  15. gts_2001

    gts_2001 Gold Member

    Joined:
    Dec 7, 2014
    Messages:
    1,329
    Likes Received:
    391
    Trophy Points:
    358
    Location:
    Grand Rapids, MI
    Vehicle:
    Challenger SRT Hellcat
    I'm pretty sure you got your car before I did (mine was delivered 12/26/14). By now, you must be a very tired of backing your Hellcat out of and back into the garage to rack up those miles. Venture out, take a drive on the wild side, At least drive it to your local 7-Eleven or Dunkin Donuts! Time to drive that baby. You're not getting any younger! :cool: (You must have the "patience of Job")
     
    • Funny Funny x 1

Share This Page