Switch Cluster Locked Up

Discussion in 'SRT Hellcat Maintenance' started by TallCool1, Aug 30, 2015.

  1. TallCool1

    TallCool1 Gold Member Hellcat Car Club Gold Supporting Member Nat'l Hellcat Tech Advisor HCC Charter Member

    Joined:
    Jan 5, 2015
    Messages:
    2,394
    Likes Received:
    791
    Trophy Points:
    458
    Location:
    Pacific NW
    Vehicle:
    Challenger SRT Hellcat
    All switches below below the HK stopped working, except the Hazzard light switch. Noticed driving it started while I was in motion. The only way I got them to work again was by disconnecting the battery. Strange. Steering wheel functions worked, good thing too I had audio loud was driving me crazy. No problems after that 1 instance. Wierd.
     
    • Useful Useful x 1
  2. solo7777

    solo7777 SRT Terminator Hellcat Car Club Western Regional President HCC Charter Member

    Joined:
    Nov 25, 2014
    Messages:
    3,045
    Likes Received:
    1,368
    Trophy Points:
    768
    Location:
    City Of The Angels
    Vehicle:
    Challenger SRT Hellcat
    Gremlins.
     
  3. Carnage

    Carnage SRT Hellcat Supercharged Moderator Staff Member Hellcat Car Club Gold Supporting Member HCC Charter Member

    Joined:
    Sep 21, 2014
    Messages:
    12,108
    Likes Received:
    3,265
    Trophy Points:
    823
    Location:
    Houston, TX
    Vehicle:
    Challenger SRT Hellcat
    ruh roh, you didn't modify your hellcat in any way yet right? :eek:
     
  4. Paladin06

    Paladin06 Have Guns Will Travel Staff Member Hellcat Car Club Gold Supporting Member

    Joined:
    Sep 3, 2014
    Messages:
    4,641
    Likes Received:
    1,785
    Trophy Points:
    778
    Location:
    San Tan Valley, AZ
    Vehicle:
    Challenger SRT Hellcat
    Hummm, strange. Any electrical mods?
     
  5. purnrg

    purnrg BANNED

    Joined:
    Apr 12, 2015
    Messages:
    2,619
    Likes Received:
    1,154
    Trophy Points:
    588
    Vehicle:
    Challenger SRT Hellcat
    Uconnect has always been a little touchy either disconnect the relay and reconnect or wait it out comes back after about 20 minutes, were you on the phone or using Bluetooth?
     
    • Useful Useful x 1

Share This Page