Uconnect Update: 8.4an_ra4_16.09.09_my16

Discussion in 'SRT Hellcat General Discussions' started by Robo21, May 8, 2016.

  1. Robo21

    Robo21 Gold Member

    Joined:
    Mar 13, 2016
    Messages:
    725
    Likes Received:
    308
    Trophy Points:
    233
    Location:
    So Cal
    Vehicle:
    Challenger SRT Hellcat
    Late last night starting at about 10:30PM I meticulously followed the directions for downloading and installing the Uconnect update but at the end of the process the screen went black. All I was getting was either a white screen with text that says "Please Insert Update USB" or a black screen with no text. :confused:

    Beginning this morning I tried calling Uconnect and Dodge support 800 numbers multiple times and we tried doing resets using the phone and VR buttons or the radio's volume and tuning buttons all to no avail. I spoke to 3 different reps hoping that one would know how to get the update to work. :confused:
    Uconnect just seemed frozen - all I was getting was either a black screen with no text or the white screen with text that said "Please Insert Update USB" The representatives all said that I would need to take the car to the dealer to get it fixed. :(

    Earlier last week I had promised my wife that we would go for a drive today up Angeles Crest Highway so late in the afternoon we got in the car and headed out the driveway when suddenly I got an urge to go back in the house and get the USB stick and try it again. I figured, what the heck, what have I got to lose by trying? I just plugged it in and we drove away. Within about a block from the house while driving the screen went from black with no text to gray with 2 progress bars and information about the updates it was loading 14 parts! Of course it began with 1 of 14 and went from there.

    It took about 30 minutes to complete and it did the entire process while we were driving. Needless to say I am ecstatic after going through all the frustration earlier. The Uconnect is working better than ever and has been completely updated. :D

    Funny thing is I remember one of the 3 reps I spoke with telling me "You cannot do this while driving, don't try that..." o_O
     
    • Funny Funny x 1
    • Useful Useful x 1
  2. JollyRoger

    JollyRoger Gold Member

    Joined:
    Sep 19, 2015
    Messages:
    1,356
    Likes Received:
    409
    Trophy Points:
    258
    Location:
    Austin, TX
    Vehicle:
    Challenger SRT Hellcat
    Glad you're back up and running!
     
    • Like Like x 1
    • Agree Agree x 1
  3. Robo21

    Robo21 Gold Member

    Joined:
    Mar 13, 2016
    Messages:
    725
    Likes Received:
    308
    Trophy Points:
    233
    Location:
    So Cal
    Vehicle:
    Challenger SRT Hellcat
    Thank you! It sure felt great when I saw the 8.4" screen light up with progress bars and begin the 14 part update.
     
    • Like Like x 1
  4. Jury

    Jury Hellcat Member

    Joined:
    Apr 19, 2016
    Messages:
    56
    Likes Received:
    10
    Trophy Points:
    8
    Location:
    San Diego
    Vehicle:
    Challenger SRT Hellcat
    Yeah. I tried this update with the car in the 'run' mode (i.e. no engine running) and it shut off after about 15 minutes--I thought it bricked my radio. I even went to Dodge dealer and had it looked at. Yesterday, like you, I just put the USB stick back in while driving and voila! It started updating again (while driving) and after about 30 mins eventually worked. Weird stuff!
     
    • Useful Useful x 2
  5. Robo21

    Robo21 Gold Member

    Joined:
    Mar 13, 2016
    Messages:
    725
    Likes Received:
    308
    Trophy Points:
    233
    Location:
    So Cal
    Vehicle:
    Challenger SRT Hellcat
    Yes! What a great feeling too. It's like being constipated for a week and then all of a sudden R-E-L-I-E-F! LOL I was not looking forward to going to the dealer's service department.

    Funny how the tech support specialists at Uconnect and Dodge are of the opinion that it cannot be done with the car running when for some of us that is the only way that it worked.
     
  6. Aarcuda

    Aarcuda Gold Member

    Joined:
    Oct 22, 2014
    Messages:
    1,428
    Likes Received:
    459
    Trophy Points:
    258
    Location:
    The Boonies
    Vehicle:
    Challenger SRT Hellcat
    i did mine while driving too. no issues other than my drive was less than the time needed for the update so i just let it idle in the driveway while it completed
     
  7. Robo21

    Robo21 Gold Member

    Joined:
    Mar 13, 2016
    Messages:
    725
    Likes Received:
    308
    Trophy Points:
    233
    Location:
    So Cal
    Vehicle:
    Challenger SRT Hellcat
    Would you say that it took about 35-40 minutes from beginning to end? It might have taken another 5 minutes after the Uconnect functionality returned for the app icons to repopulate. After the update completed I noticed a place-holder icon with an image of an exclamation point in the middle, it wasn't long before the app icons were back.
     
  8. Slowpoke387

    Slowpoke387 VIP Hellcat Member

    Joined:
    Jan 31, 2016
    Messages:
    790
    Likes Received:
    212
    Trophy Points:
    73
    Location:
    Enfield, CT
    Vehicle:
    Challenger SRT Hellcat
    So by ur post title u have a '16? Im curious to know what this update did for you. I picked up my '16 about a wk ago am wondering what HK update is available already. Thought it was a '15 update to '16 specs but if urs is a '16 im curious.

    *edit* so i googled it and found my answer lol. It is the previous update that my '16 came with already.
     
    Last edited: May 9, 2016
  9. Catless

    Catless Silver Member

    Joined:
    Feb 2, 2015
    Messages:
    944
    Likes Received:
    192
    Trophy Points:
    153
    Location:
    Parkersburg, WV
    Vehicle:
    Challenger SRT Hellcat
    I suspect they are just not going to suggest anybody run the update while driving to avoid any liability. I did the update on my '15 in the ignition mode (not running) and it worked fine. I did notice that the left audio channel did not work until I did an addition on/off/open door cycle as stated in the instructions.
     
    • Like Like x 1
  10. Robo21

    Robo21 Gold Member

    Joined:
    Mar 13, 2016
    Messages:
    725
    Likes Received:
    308
    Trophy Points:
    233
    Location:
    So Cal
    Vehicle:
    Challenger SRT Hellcat
    Interesting, when I went to update my '16 (Build Date 1/27/16) the version number of the existing firmware/software was indeed different than the update, meaning of course that doing the update was indicated. Typically, by just inputting your VIN here:Uconnect® Software Update - Update your Uconnect® System you will find out if there are any updates for your specific vehicle by VIN.
     
  11. Phisco65

    Phisco65 Gold Member

    Joined:
    Apr 24, 2015
    Messages:
    519
    Likes Received:
    260
    Trophy Points:
    313
    Location:
    SW Florida
    Vehicle:
    Challenger SRT Hellcat
    I had a similar experience doing the update in RUN mode, as directed. It seemed like the car timed out and power was cut to the radio / USB port. I cycled through the OFF/ACC/RUN modes with USB stick still inserted and waited. It restarted after 3 or 4 minutes but timed out again after going through 12 of the 14 units.:mad:

    Ran through the OFF/ACC/RUN modes again and waited. Once it restarted and even though it highly recommends not doing so, I ran through the OFF/ACC/RUN modes. Did it again after it got through 7 of the 14 units. Finally, ran through all units and updated successfully. Took over an hour. Good thing I like sitting in my car. :D

    I then followed that same sequence (running through OFF/ACC/RUN modes every so often) on my '16 Grand Cherokee with the same radio and had success the first time through. That one only took about 20 minutes to do.
     
  12. Jury

    Jury Hellcat Member

    Joined:
    Apr 19, 2016
    Messages:
    56
    Likes Received:
    10
    Trophy Points:
    8
    Location:
    San Diego
    Vehicle:
    Challenger SRT Hellcat
    My radio went black after it shut down half way through the update and then stayed "bricked" for about 3 days. I left the USB stick in and in the middle of a drive a few days later, the radio randomly decided to start updating again. My advice to those trying the MY16 update at home is to do it while the engine is running.
     
    • Useful Useful x 1
  13. Robo21

    Robo21 Gold Member

    Joined:
    Mar 13, 2016
    Messages:
    725
    Likes Received:
    308
    Trophy Points:
    233
    Location:
    So Cal
    Vehicle:
    Challenger SRT Hellcat
    Yep, we had a very nice drive up to the beginning of the Angeles Crest Highway. By that point it had finished the entire update except for repopulating the app icons. The whole procedure was much more pleasant then sitting there staring at a blank screen waiting for the update to happen.
     
  14. nmaggio

    nmaggio Rookie

    Joined:
    Dec 4, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Vehicle:
    Charger SRT Hellcat
    did the "please insert update USB" screen stay solid or did the radio keep going black then coming up with that screen?

    mine keeps resetting talked to the dealer that i know very well and they are pretty sure its best to put a new radio in it.
     
  15. Jury

    Jury Hellcat Member

    Joined:
    Apr 19, 2016
    Messages:
    56
    Likes Received:
    10
    Trophy Points:
    8
    Location:
    San Diego
    Vehicle:
    Challenger SRT Hellcat
    Mine went black and stayed that way for a couple days. During my last drive it suddenly popped up with the grey "updating screen".
     

Share This Page

Search tags for this page
2014 uconnect update embedded
,
dodge challenger uconnect update
,
hellcat screen went black
,
uconnect embedded aircard
,

uconnect software update stalls at the embedded aircard what do i do

,
uconnect update 08-057-16
,

uconnect update stalled when the embedded aircard test stalled

,
why is uconnect update stopping at embedded aircard on dodge ram