SRT Hellcat Forum banner

41 - 50 of 50 Posts

·
Registered
Charger SRT Hellcat
Joined
·
1,257 Posts
Good question... don’t know... gonna look for the manual.
 

·
Registered
Joined
·
5 Posts
I've got a little clunk, sounds like a driver side half shaft cv joint, hasn't gotten any worse but probably should get it checked out.


Sent from my SM-N920T using Tapatalk
Greetings Slidd, thanks for your post. I have the same vehicle and I'm experiencing the same issue for the first time after 40,000 miles. The dealer has had my car for a couple of days now and have not been able to determine the solution. Did you ever determine the source of the clunking and did you get the issue resolved, thanks?
 

·
Registered
Joined
·
335 Posts
My car does this when putting it into drive. I assumed it was normal....2019 3,600 miles.
 

·
Registered
Challenger SRT 392
Joined
·
5,214 Posts
Greetings Slidd, thanks for your post. I have the same vehicle and I'm experiencing the same issue for the first time after 40,000 miles. The dealer has had my car for a couple of days now and have not been able to determine the solution. Did you ever determine the source of the clunking and did you get the issue resolved, thanks?
I have not. It still does it but has not gotten any worse and I'm starting to think that it is normal. I've crawled under there and did not notice anything unusual or what seemed like excessive play. Over 20,000 miles and still going strong. I hate going to the dealer so I'm gonna just let it ride.

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
5 Posts
Hello Slidd, I am grateful for your response. The dealer has decided to replace my transmission since it was still under warranty by 4 days! This has been a terrible experience. If it does it again I am going to let it ride as well.
Thanks again. Regards.
 

·
Registered
Joined
·
5 Posts
My car does this when putting it into drive. I assumed it was normal....2019 3,600 miles.
Hey Granitecitycat, thanks for your response. I question whether this is normal; however, based on my experience with the dealership spinning their wheels trying to determine the cause, I would recommend accepting it as normal in hindsight. My vehicle has been in the shop for over a week now and I'm increasing losing confidence that they will truly rectify the problem.
 

·
Registered
Joined
·
335 Posts
Hey Granitecitycat, thanks for your response. I question whether this is normal; however, based on my experience with the dealership spinning their wheels trying to determine the cause, I would recommend accepting it as normal in hindsight. My vehicle has been in the shop for over a week now and I'm increasing losing confidence that they will truly rectify the problem.
Are they no longer replacing the transmission?
 

·
Registered
Joined
·
5 Posts
Are they no longer replacing the transmission?
Well, I was advised that my transmission was replaced on Saturday February 15th but apparently they have to run my car through a series of tests to make sure it is fixed; at least that is what I was told Saturday morning. I was advised that I will receive a call Monday with an update. It is now Tuesday 2/18 and as for 2:20 pm est, I haven't receive a call or an email with any updates. I will provide a complete update once this ordeal is over.
 

·
Registered
Joined
·
5 Posts
Latest update: Dodge called shortly after my previous update earlier today to inform that the new transmission was installed and the service completed. Although the problem appears to be resolved, it is too early to confirm at this point. The new transmission has a 3 year 50,000 warranty which is great. Though this has not been a good experience, the dealership put forward a good effort to make up for my dissatisfaction with how things were going. Note that initially, the dealer replaced the valve body; however when that didn't resolve the problem, Chrysler approved replacing the Trans Unit. I will provide a follow up if there are any issues.

Regards.
 
41 - 50 of 50 Posts
Top