SRT Hellcat Forum banner
  • Hey Everyone! Vote for the Site Favourite HOTM winner for the year of 2022 HERE!
1 - 20 of 24 Posts

· Registered
Charger SRT Hellcat
Joined
·
188 Posts
Discussion Starter · #1 ·
Just wondering if any of youhave had this problem. I installed thebwoody idler pulley and it started squeaking. It has now gotten progressively worse and its almost as loud as the intake now!

Any ideas on how to make this irritating noise go away?!?!
 

· Registered
Charger SRT Hellcat
Joined
·
188 Posts
Discussion Starter · #7 ·
Sorry I was doing the family thing yesterday and didnt reply guys. I haven't contacted bap, I wanted to see if the issue was fairly common or not. I have the steel one and so does one of my friends. Both cars squeak. Pretty irritating but the pulley still functions properly.
 

· Premium Member
Challenger SRT Hellcat
Joined
·
524 Posts
We have only had one other pulley that the bearing went bad, it was a steel one. contact us on monday and we will call molar to try and get it warrantied for you.
 
  • Like
Reactions: GOMER and 11sec76

· Premium Member
Challenger SRT Hellcat
Joined
·
524 Posts
I'm curious to know myself. Considering ordering the metco idlers along with a 3.10 SC pulley and the ATI lower
The Metco Idlers are a very nice addition to the cat, our older pulley is in a completely different location and we do offer a metro upgrade for those that have the metro idlers on their vehicle.
 

· Registered
Charger SRT Hellcat
Joined
·
188 Posts
Discussion Starter · #11 ·
We have only had one other pulley that the bearing went bad, it was a steel one. contact us on monday and we will call molar to try and get it warrantied for you.
just a FYI follow up, while my car was in the shop this past weekend getting a smaller pulley put on, I had the tech look at it. turns out that the factory bolt that was reused to put the pulley bracket back on was just barely too long. it was grazing the back of the pulley and causing the squeaking. so we took off a quarter inch and theres no more squeaking!

I never noticed it rubbing because it was never noticeable when I was at home with the hood up. who would have though it was so simple!

thanks again Mike!
 

· Premium Member
Challenger SRT Hellcat
Joined
·
524 Posts
just a FYI follow up, while my car was in the shop this past weekend getting a smaller pulley put on, I had the tech look at it. turns out that the factory bolt that was reused to put the pulley bracket back on was just barely too long. it was grazing the back of the pulley and causing the squeaking. so we took off a quarter inch and theres no more squeaking!

I never noticed it rubbing because it was never noticeable when I was at home with the hood up. who would have though it was so simple!

thanks again Mike!
As per the instructions, you were not supposed to re-use any of the OEM hardware, you were supposed to use only the hardware that we supplied in the kit.
 

· Premium Member
Challenger SRT Hellcat
Joined
·
524 Posts
WOW, that's a 10.8 grade bolt, never had one break before. Call in to Breanna she will send you a new one.
 
  • Like
Reactions: 11sec76

· Registered
Challenger SRT Hellcat
Joined
·
503 Posts
WOW, that's a 10.8 grade bolt, never had one break before. Call in to Breanna she will send you a new one.
A 10.8 bolt is strong but brittle, like cast iron. A harden bolt sometimes can work against you. You may want to consider using a Grade 8 bolt instead.
 

· Banned
Challenger SRT Hellcat
Joined
·
478 Posts
Just wondering if any of youhave had this problem. I installed thebwoody idler pulley and it started squeaking. It has now gotten progressively worse and its almost as loud as the intake now!

Any ideas on how to make this irritating noise go away?!?!
I just installed mine and it's been about 100 miles and I can hear the bearings getting louder and louder too.
 

· Banned
Challenger SRT Hellcat
Joined
·
478 Posts

· Premium Member
Challenger SRT Hellcat
Joined
·
524 Posts

· Registered
Challenger SRT Hellcat
Joined
·
4,019 Posts
Looks like my steel pulley didn't even survive 30+ run.. It started making bearing noise..

I've removed the pulley/bracket and would use the proper belt I guess... My buddy sent me his Metco pulley but somehow it has no bolt or holding washer so it's not usable either..
 
1 - 20 of 24 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top