SRT Hellcat Forum banner
  • Hey Everyone! Vote for the Site Favourite HOTM winner for the year of 2022 HERE!

HELP Tazer screwed up my car!!

4468 Views 13 Replies 7 Participants Last post by  Spartacus
Ok so just installed the double bypass and the tazer in my 2019 HC RE WB. It was a refurb unit from Z Automotive. I upgraded the firmware to the latest. It already had some settings on it when I plugged it in. It had all sorts of stuff turned on. So I used the manual to put settings back to what I think they should be. I even turned off the settings that might pertain to my car because I don't need SRT pages when my car comes with it, maybe that was a mistake, but the instructions and videos don't tell you the whole story.

Anyway, I figured turning off those things like SRT pages might affect the car even though they come with the car as stock. But I did the reboot and 2 car sleeps and tried all the functions. Everything worked and the settings that MY tazer came with stayed off, such as start in Track Mode.

Now today I go to drive and the backup camera isn't working and SRT button the console isn't either. I tried unmarry a few times following the instructions on how to do so. I married it again and checked the settings and the settings I turned off are back on, stock settings I assume, such as camera and SRT pages. Ok maybe those should have be on, but no harm they are on now. Still nothing works. I tried unmarry again and pulled it out of the car and still nothing.

Please help! I texted Z Automotive from the urgent number on the website and emailed and haven't heard back.
1 - 2 of 14 Posts
Until I read this, I was thinking of buying a Tazer just to primarily to mask the TPMS dash warning light. I don't want to mess up my car. Any comments or advice? unsure what to do.
Thank you for taking the time to reply to my post. I think I'll wait to purchase the Tazer to see if things get better with Z Automotive.
1 - 2 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.