SRT Hellcat Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 20 of 27 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Hey all! I just picked up my 2014 JGC SRT with 47k miles on it. I get a weird hesitation only in 1st gear that I have noticed. It is kind of like a stutter when I accelerate quickly. It feels like it cuts fuel then keeps going.

Has anyone had this issue and identified it? I did get some new plugs just to swap those out and I cleaned the map sensor. The diffs and Tcase all have fresh fluid in them as well.

TIA!
 

·
Super Moderator
Charger SRT Hellcat
Joined
·
7,239 Posts
Hi Welcome to Hellcat.org.

I'm sure there are members on here that can help you.
Vertical Scope has another Forum Cherokee SRT8 Forum that may be more helpful to you.
There are a lot of racers from the MSHS series that I know and can answer questions too.

Cheers
Linda
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #3 ·
Thank you! I appreciate it :) I am a member of that forum as well! I prefer the members and the diversity here. Definitely a great experience already.
 

·
Super Moderator
Charger SRT Hellcat
Joined
·
7,239 Posts
Exactly you do have diversity here!

Do you race your Jeep at the Dragstrip?

Linda :)
 

·
Registered
2020 Challenger Hellraisin Scat Pack.
Joined
·
2,554 Posts
Hey all! I just picked up my 2014 JGC SRT with 47k miles on it. I get a weird hesitation only in 1st gear that I have noticed. It is kind of like a stutter when I accelerate quickly. It feels like it cuts fuel then keeps going.

Has anyone had this issue and identified it? I did get some new plugs just to swap those out and I cleaned the map sensor. The diffs and Tcase all have fresh fluid in them as well.

TIA!
Used vehicle can have questionable gasoline. Have you driven the vehicle enough to be able to refuel with fresh gasoline of the proper grade?

Another thing to check is the engine air filter. I let the one in my Hellcat go to 27K miles -- I think it is scheduled to be changed at 20K miles. The engine air filter (and cabin air filter) was filthy. With a new engine air filter installed the Hellcat engine's throttle response was markedly better and a bit of hesitation was gone. The degradation was gradual that I sort of didn't notice it but with the new filter installed I couldn't help but notice the improvement.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #7 ·
Used vehicle can have questionable gasoline. Have you driven the vehicle enough to be able to refuel with fresh gasoline of the proper grade?

Another thing to check is the engine air filter. I let the one in my Hellcat go to 27K miles -- I think it is scheduled to be changed at 20K miles. The engine air filter (and cabin air filter) was filthy. With a new engine air filter installed the Hellcat engine's throttle response was markedly better and a bit of hesitation was gone. The degradation was gradual that I sort of didn't notice it but with the new filter installed I couldn't help but notice the improvement.
Yes and no. I do not know what they filled it up with when I left the dealer. I did get it down to a 1/4 of a tank and put some Shell 91 in. But with winter and the shutdown I am not sure how many people are using that 91 either.

Good point! I will check the filter because I already pulled my cabin filter and it was incredibly dirty. When I did the diffs and the tcase it was almost black. It should have been done at least 2x by now but it looked like OEM fill. For the hell of it I did buy some new spark plugs as well. Since 6 years in a vehicle for plugs could definitely cause in issue (in my crazy mind) it will be cheap insurance.
 

·
Registered
2020 Challenger Hellraisin Scat Pack.
Joined
·
2,554 Posts
The odds are the 91 you filled up with had to be fresher than what was in the fuel tank. If the fresh 91 didn't help then likely not stale or just bad gasoline.

I'm really leaning towards the engine air filter. I'd replace that or have it replaced then road test the car.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #9 ·
I just went out and checked it and it is new. Looks like it is a WIX filter from the PN on it. So that is good news. But now back to square one lol
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #10 ·
Well I think I figured out the issue. I have not taken it out for a true drive yet it does feel a lot better all across the board. This one was the cleanest plug and the rest were bad. A lot of carbon. One had cracked porcelain and another had something peeling off of the electrode that I have no idea what it was.
569912
 

·
Registered
2017 Challenger SRT Hellcat
Joined
·
951 Posts
Wow, I have 42,000 on my 2015. Runs great still, but now you have me wondering what the plugs look like.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #12 ·
I know on my F150 ecoboost that was tuned I changed plugs every 10k miles. The heat would cause the gap to widen and it would start having some misfires since it was so sensitive to plugs and gap. They are relatively cheap and easy to do so I change them out every 20k miles on everything else. Forced induction is a lot harder on plugs as well due to cylinder pressure and heat.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #13 ·
Just a quick update. This is still present and still annoying me haha. I wonder if it is a dealer/software thing. I am going to be taking it in next week for them to look at.
 

·
Super Moderator
Jeep GC Trackhawk
Joined
·
2,517 Posts
Have you tried running it in different Modes to see how that affects the hesitation?

In other words, does it hesitate the same in Track mode as it does in Sport or Automatic mode?
 
  • Like
Reactions: ChevoFuerte

·
Registered
Joined
·
24 Posts
Discussion Starter · #15 ·
Have you tried running it in different Modes to see how that affects the hesitation?

In other words, does it hesitate the same in Track mode as it does in Sport or Automatic mode?
Yes I have and it seems to get progressively "worse" with each mode. IE the more aggressive the tip in the more pronounced the issue is. in Auto light throttle it isn't there, but with more aggressive throttle it is present. I think the throttle sensitivity in the different modes exacerbates it. I am starting to think it could be a software thing. There was multiple TSBs and software updates for the trans from 2014 to 2016. From what I gather it has never been updated or touched. It is still on an early CAL. So much so my diablo doesn't support tuning it but it can see it.
 

·
Registered
Charger SRT 392
Joined
·
268 Posts
I know this may sound dumb but have you tried disconnecting the battery for 30 minutes or so to clear anything out from the previous owners driving habits? I had another person with a similar issue and that resolved it for them.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #17 ·
I know this may sound dumb but have you tried disconnecting the battery for 30 minutes or so to clear anything out from the previous owners driving habits? I had another person with a similar issue and that resolved it for them.
I appreciate the sanity check. Correct I did disconnect the battery for about an hour and left the headlights on to drain any sort of residual power. I also did the TB relearn just in case it was something like that as well.
 

·
Registered
Charger SRT 392
Joined
·
268 Posts
Damn, I was hoping it was something easy. We all go extreme and often miss the little stuff. I'm curious what you find out it is now.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #19 ·
Damn, I was hoping it was something easy. We all go extreme and often miss the little stuff. I'm curious what you find out it is now.
I appreciate it! Hopefully the dealer has some insight. The fluids were dark when they were changed. I have some extra oil laying around so I may do another drain and fill of the t case just so I feel like im doing something. It cant hurt. I have a feeling the dealer may be helpful when I take it in. They have usually been pretty good at diagnosing and actually fixing the issue or at least straight up saying we don't know but it isn't an issue. I just hate the feeling when I take off and it cuts out really quick.
 

·
FCA Official
Challenger SRT Hellcat
Joined
·
386 Posts
Just a quick update. This is still present and still annoying me haha. I wonder if it is a dealer/software thing. I am going to be taking it in next week for them to look at.
Hi ChevoFuerte,
We sincerely regret to hear of your trouble. Please feel free to keep us updated regarding your situation. If we can be of any additional support while your vehicle is in service, we're just a PM away.

Rob
Dodge Cares
 
  • Like
Reactions: ChevoFuerte
1 - 20 of 27 Posts
Top