SRT Hellcat Forum banner
  • Hey Everyone! Vote for the Site Favourite HOTM winner for the year of 2022 HERE!
1 - 18 of 18 Posts

· Registered
Challenger SRT Hellcat
Joined
·
644 Posts
Discussion Starter · #1 ·
Just went out to move it so I could get to the engine, and the strangest thing, it wouldn't start! Has power and everything, so I don't think it is battery. Happen to you? Engine light stays on after it doesn't start. No turnover or anything. Haven't driven it in a couple of weeks. Been covered. Any Ideas?? Dash looks like it does when starting, just nothing after that. Engine light stays on and ignition indicates Run position. Wonder if it is in Shipping mode. I tried to put that on, and also tried to turn it off. I ran Diagnostics too, nothing came up.
Thanks in advance for any help!
Jim
 

· Registered
Challenger SRT Hellcat
Joined
·
1,695 Posts
I think it could be the battery. Even though horns and lights and other amenities may function, it takes a lot of power, to actually turn over a motor. So a car may have plenty of 'power' for accessories, but the battery may not have the amps to actually crank the engine. And batteries are hit or miss, sometimes they last for years, the next time, a brand new one might fail in a month, could just be bad luck! In any case, hope it's something minor, and your 'cat is on the road soon!
 

· Premium Member
Joined
·
13,620 Posts
Just went out to move it so I could get to the engine, and the strangest thing, it wouldn't start! Has power and everything, so I don't think it is battery. Happen to you? Engine light stays on after it doesn't start. No turnover or anything. Haven't driven it in a couple of weeks. Been covered. Any Ideas?? Dash looks like it does when starting, just nothing after that. Engine light stays on and ignition indicates Run position. Wonder if it is in Shipping mode. I tried to put that on, and also tried to turn it off. I ran Diagnostics too, nothing came up.
Thanks in advance for any help!
Jim
I dunno, sometimes I have to push Start a couple times because my car doesn't read the key in it. Maybe DrBuick knows. Did your car have the recall?
 

· B5 Demon #2600, 1 of 1
Challenger SRT Demon
Joined
·
747 Posts
Just went out to move it so I could get to the engine, and the strangest thing, it wouldn't start! Has power and everything, so I don't think it is battery. Happen to you? Engine light stays on after it doesn't start. No turnover or anything. Haven't driven it in a couple of weeks. Been covered. Any Ideas?? Dash looks like it does when starting, just nothing after that. Engine light stays on and ignition indicates Run position. Wonder if it is in Shipping mode. I tried to put that on, and also tried to turn it off. I ran Diagnostics too, nothing came up.
Thanks in advance for any help!
Jim
I would follow the jump starting instruction and try that, sounds like the battery maybe low from sitting if you don't have a volt meter to check the voltage of the battery. My SRT 10 will do that after a couple of weeks of sitting if I forget to hook up my battery tender. Good luck on getting it started :cool:
 

· Registered
Charger SRT Hellcat
Joined
·
6,854 Posts
If the car is running and the battery light is on that's not a battery-Connection issue it sounds like which would cause the no crank
 

· The Punisher
Challenger SRT Hellcat
Joined
·
1,124 Posts
I had my fobs in the kitchen near my garage (previous SRT) and it would drain the battery...moved the fobs upstairs and had no more issues with drained batteries. Just a thought.
 

· Premium Member
Joined
·
13,620 Posts
I had my fobs in the kitchen near my garage (previous SRT) and it would drain the battery...moved the fobs upstairs and had no more issues with drained batteries. Just a thought.
I never really thought about that! I keep my spare keys by the garage door. I think I will move them farther away. Thanks.:)
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top