SRT Hellcat Forum banner

21 - 40 of 40 Posts

·
Tri-State Overlord
Joined
·
2,274 Posts
they are over doing what needs to be done to verify the problem, either for additional billing or they literally have no idea what they are doing
 

·
Registered
Joined
·
380 Posts
mine is doing the same thing. I thought it was maybe a bypass valve issue. 1200 miles on mine. But...im not even going to try to mess with the dealer on it. If it gets worse ill pull the drive motor off and lube the valve. At least i know what it is now. Thanks internet!
 

·
Registered
Joined
·
200 Posts
Discussion Starter #25
Yep it's almost not worth fighting the dealer to get it swapped out. Drive it in track mode and call it good. It just really pisses me off the few times I have it in street as I'm parking or going through someplace slowly and I'm squeaking like i got a POS car... not what I like to hear after dropping 70k!
 

·
Registered
Joined
·
200 Posts
Discussion Starter #26
Finally! The mechanic was able to replicate the issue and got it recorded on the 'chassis ears', they talked to Chrysler and got the green light for ordering a new exhaust system. I was happy they gave me 4 free oil changes for my inconvenience. At roughly 90$ a pop that's a great make up for this hassle.

My SA told me this is the first STAR case that has been opened regarding this issue, according to him. If I get that info I'll pass it along so hopefully anyone who has this problem can simply reference the case and get it diagnosed and fixed much quicker than multiple trips to the dealer.
 

·
Registered
Joined
·
200 Posts
Discussion Starter #28
considering most of us had it swapped already it's not the first star case but it's a good bullshit answer to make customers happy
True but unless someone actually gets the info and puts it on this forum it may as well be the first one every time. Telling them a dozen people on a forum that had the same problem doesn't mean jack unless we have something we could point to, aka other star cases.
 

·
Registered
Joined
·
378 Posts
Mine valves could be heard squeaking easily on a remote start. Just hit the switch, wait a couple seconds after startup and it was obvious every single time.
 

·
Texas President
Joined
·
2,596 Posts
Anybody record the "squeaking sound"??? I don't have the problem just want to hear what all of u are talking about!!
 

·
Banned
Joined
·
169 Posts
So I have the squeak too. What are my options? I don't mind it. Heck I'm usually blasting ACDC and with my mid muffler delete, yeah, you get the picture. But is Dodge really replacing exhaust systems if you have the squeak?
 

·
Registered
Joined
·
25 Posts
Just had this happen on my hellcat i started to notice it when i turn on the ignition but dont start the car you can hear them squeaky like stupid the vales echo through the resonator made them sound louder if the resonators were the problem but it was just the vales echoing through them


take your accurators off and spray wd40 and turn it manually by hand on the vales BOOM problem fix

Just fix mine today screw the dealer if that was the case just delete the vales haha


Hope this helps anyone having this problem
 

·
Registered
Joined
·
10 Posts
Yup, I had the same issue. Its covered under basic warranty but not powertrain. Mine started after Basic expired though so I got the M-FER mod, which tricks out the active exhaust to stay open (“track mode”). $150 I think it was. They tried wd40 on the valves but it didn’t work
 

·
Registered
Joined
·
26 Posts
Anyone else hear the exhaust cutout opening and closing as they press on the throttle? I just noticed this today as I was coming down the street maybe 10-15 mph, as i give it some gas I hear something squeak as if it's opening, then as i let off the throttle it squeaks again... it's like it needs some WD-40 or something.

Is this really what could be causing the noise? it aligns perfectly to the throttle input.
funny thing. At 14,000 miles I noticed the driver side valve squeak loudly when it would start up using my remote start. Driving when you tip the throttle slightly it would squeak here and there. I was ready to take it apart and lube it up when it dawned on me, why don't I put some Lucas octane boost which is a little oily. And drive the car hard. The results the squeaking went away! no joke I guess Mopar relies on the carbon from your exhaust to keep them Lube. Give it a shot put some octane boost and drive the shit out of your car.
 
21 - 40 of 40 Posts
Top