SRT Hellcat Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
2015 hellcat charger
Joined
·
36 Posts
Discussion Starter · #1 ·
Unhooked battery now I’m stuck here won’t do anything but keep goin back to this I don’t have connect subscription



Sent from my iPhone using Tapatalk
 

·
Registered
Challenger SRT Hellcat Widebody
Joined
·
2,068 Posts
Does this come up only when you go for the Performance Pages, the Settings Menu, or all the time?

The PP is known for being temperamental. Shutting the car off and turning it back on usually clears it up.

If it's coming up on the SRT page, that's a new one on me.

If it's coming up ALL THE TIME then either it's waiting for a push update OR it's time for a dealer visit for bad hardware.
 

·
Registered
Joined
·
51 Posts
Let the car sit outside for a few hours. It will go back to normal. I had the same issue with my 2020. It looks like it has to connect to the satellite and update again.
 

·
Registered
Charger SRT Hellcat
Joined
·
391 Posts
Luckily you have a 2015 and can do a soft reset on the uconnect with right button press combo. Try that process.

My 2018 Trackhawk did this same thing and with the newer Panasonic unit they did away with the soft reset and I had to go to dealer to have it reset. I tried unhooking battery several times and people on here kept telling me eventually they will just come back to life. I gave mine 8 weeks of daily driving before I went to dealer
 
1 - 6 of 6 Posts
Top