SRT Hellcat Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 13 of 13 Posts

·
Registered
Charger SRT Hellcat
Joined
·
81 Posts
Discussion Starter · #1 ·
My 21 hellcat charger (with the HK system) has had this problem from day one. Because I got the car in the fall, I didn't have much time to deal with it. Parked car for the winter. The U connect voice has static when she speaks. Navigation as well. Phone calls are perfectly clear. Zero static from speakers when listening to the radio. Had the car checked out in the spring. There is a TSB for static from dashboard speakers, not the problem. My Amp is updated. They decided to change the telematics module (part of the radio). After 5 weeks, the radio showed up, plugged in and no difference. Changed dashboard speakers, no difference. I'm curious if anyone else has had this problem and any remedies? Not a major issue, just an annoyance.
 

·
Registered
Charger Hellcat Redeye
Joined
·
42 Posts
I have a similar, but different issue. 21 Charger Redeye, HK system. I use Apple CarPlay 95% of the time. Music clear, phone calls all static. It’s irritating and I won’t take calls unless I have to.

Interested in that TSB number… maybe it’ll help my issue.
 

·
Registered
Charger SRT Hellcat
Joined
·
81 Posts
Discussion Starter · #3 ·
I have a similar, but different issue. 21 Charger Redeye, HK system. I use Apple CarPlay 95% of the time. Music clear, phone calls all static. It’s irritating and I won’t take calls unless I have to.

Interested in that TSB number… maybe it’ll help my issue.
TSB # 08-078-21

hopefully it'll help your issue.
 

·
Registered
Charger SRT Hellcat Widebody Redeye
Joined
·
139 Posts
My may 21 built charger redeye with hk has been installing messages.jar for a year and is nowhere near loud enough at max volume 38.
 

·
Registered
Joined
·
83 Posts
What do you mean by static? My 2022 HCWB Charger has crackling noises only when speaking over the phone. Is that what you mean? I wonder what the fix is as well. Planning to report it when changing oil.


Sent from my iPhone using Tapatalk
 

·
Registered
Charger SRT Hellcat
Joined
·
81 Posts
Discussion Starter · #8 ·
My problem is very unusual. It's only the female voice (uconnect/navigation and VR) that seems to be static like (crackling). The phone calls are clear and zero issues when listening to the radio. it's really a head scratcher. My technician (who happens to be my best friend) has never seen this type of issue before. New radio and dashboard speakers and no change. More of an annoyance than anything.
 

·
Registered
Joined
·
583 Posts
My problem is very unusual. It's only the female voice (uconnect/navigation and VR) that seems to be static like (crackling). The phone calls are clear and zero issues when listening to the radio. it's really a head scratcher. My technician (who happens to be my best friend) has never seen this type of issue before. New radio and dashboard speakers and no change. More of an annoyance than anything.

your tech, and no offence has no idea what he is doing, and your problem its not unusual. The static is due to the absolute bogger eating clowns Dodge hired to create and program the uconnect. Its 2022, the uconnect system sounds like a Speak and Spell from the 80's. Yours is not the only one that sucks, mine does the exact same thing and so does everyones. I've been in other ars and they do the same thing. There is NO fix for it. Think of how crappy the rear camera is, the static, while not part of the programming, is a direct result of how they programed it. To fix it Dodge would have to revamp the architecture of the whole system, which is not going to happen.
 

·
Registered
Charger SRT Hellcat
Joined
·
81 Posts
Discussion Starter · #10 ·
your tech, and no offence has no idea what he is doing, and your problem its not unusual. The static is due to the absolute bogger eating clowns Dodge hired to create and program the uconnect. Its 2022, the uconnect system sounds like a Speak and Spell from the 80's. Yours is not the only one that sucks, mine does the exact same thing and so does everyones. I've been in other ars and they do the same thing. There is NO fix for it. Think of how crappy the rear camera is, the static, while not part of the programming, is a direct result of how they programed it. To fix it Dodge would have to revamp the architecture of the whole system, which is not going to happen.
I know what you mean. No offence taken. I'm a mechanic myself. The techs have very few options at their disposal. When he called the engineering department, they didn't know either. Easiest option was to change the module...I figure I'm going to have to live with it. It's really not a big deal. My calls are clear and so is the radio. Just the Uconnect voice. I was just curious as to other cars.
 

·
Registered
Joined
·
583 Posts
I know what you mean. No offence taken. I'm a mechanic myself. The techs have very few options at their disposal. When he called the engineering department, they didn't know either. Easiest option was to change the module...I figure I'm going to have to live with it. It's really not a big deal. My calls are clear and so is the radio. Just the Uconnect voice. I was just curious as to other cars.

The radio, contrary to what others have said sounds pretty good to me.
 

·
Registered
Joined
·
83 Posts
All in all sounds great but the calls are crackling bad. Anyone had exactly the same and fixed it? First I thought it’s speaker transmitting calls or it’s loose connection but now that I read this thread I’m not sure anymore.


Sent from my iPhone using Tapatalk
 
1 - 13 of 13 Posts
Top