SRT Hellcat Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 11 of 11 Posts

·
Registered
Challenger SRT Hellcat
Joined
·
921 Posts
Discussion Starter · #1 ·
hey all....2016 challenger hellcat. i just replaced my battery & noticed my clock was 3 hrs off. I went into clock settings & noticed the box was checked (sync clock with nav) when i uncheck the box the time is correct...if i check the box it changes back to 3 hrs off & it wont let me change the time if the box is checked....any ideas?...thanks all...
 

·
Registered
Charger SRT Hellcat
Joined
·
920 Posts
hey all....2016 challenger hellcat. i just replaced my battery & noticed my clock was 3 hrs off. I went into clock settings & noticed the box was checked (sync clock with nav) when i uncheck the box the time is correct...if i check the box it changes back to 3 hrs off & it wont let me change the time if the box is checked....any ideas?...thanks all...
Let it have overnight...
 

·
Premium Member
2020 Challenger Hellcat Redeye Wide Body
Joined
·
10,105 Posts
What he ^^^ said. Takes time.
 

·
Registered
Challenger SRT Hellcat
Joined
·
921 Posts
Discussion Starter · #4 ·
i just checked & still no change...i just went online to uconnect & found theres an update for the 2016's....downloaded it & going to install .....hopefully this will fix my problem.....will update later....
 

·
Registered
Charger SRT Hellcat
Joined
·
920 Posts
i just checked & still no change...i just went online to uconnect & found theres an update for the 2016's....downloaded it & going to install .....hopefully this will fix my problem.....will update later....
Have you checked your Settings to make sure your Clock sets Automatically and your GPS Settings are good??
 

·
Registered
Challenger SRT Hellcat
Joined
·
921 Posts
Discussion Starter · #8 ·
when i check the box to syns clock goes 3 hrs behind....uncheck box & I'm able to set manually....all happened after disconnecting for battery swap....uconnect customer service says update needed....radio reset when i disconnected it... we will see...
 

·
Registered
2021 SRT Super Stock
Joined
·
335 Posts
when i check the box to syns clock goes 3 hrs behind....uncheck box & I'm able to set manually....all happened after disconnecting for battery swap....uconnect customer service says update needed....radio reset when i disconnected it... we will see...
again, probably has something to do with time zones. have you checked your nav to see what city it's set for?
 

·
Registered
Challenger SRT Hellcat
Joined
·
921 Posts
Discussion Starter · #10 ·
didnt think of that, will have to check....would it still show my proper location on the map? if that was wrong?
 

·
Registered
Challenger SRT Hellcat
Joined
·
921 Posts
Discussion Starter · #11 ·
update... I upated the software & problem solved....thanks for all the input.....
 
1 - 11 of 11 Posts
Top