SRT Hellcat Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 20 of 29 Posts

·
Registered
Challenger SRT Redeye
Joined
·
717 Posts
Discussion Starter · #1 ·
@DodgeCares

Car is at the dealership. 2019 Redeye….phone is an IPhone SE

Everything worked fine up until a few months ago. Then out of the blue the CarPlay stopped working. In addition when I have it plugged into the USB port it says “device not recognized”. Before it went to the dealer I did everything shown online to fix the issues. I then spent about an hour and a half on the phone with UConnect doing essentially the same thing again.

So I get an email today saying essentially my phone and software are too new and the system won’t recognize (doesn’t surprise me dealer is trying to blame me or something I did). I told them there’s no way that’s the case. If it was I’m sure I wouldn’t be the ONLY one with this issue.

So if you have a model year 2019 car and an IPhone I’d appreciate it if you’d post in here with your model car, model IPhone, and what software your phone currently has. I’m at my wits end with this and the dealership.
 

·
Registered
Challenger SRT Redeye
Joined
·
717 Posts
Discussion Starter · #3 · (Edited)
Looking for model year 19 owners (or newer) that use iPhones to post what model iPhone and what software the iPhone is running. Thanks!
 

·
Premium Member
2020 Challenger Hellcat Redeye Wide Body
Joined
·
10,247 Posts
I’m thinking 2019+ would be the same, not 2019 and older. Didnt the ECU change after 2018?
My 2020 works with my iphone 12 Pro Max with the latest ios. I even added a wireless Carplay dongle to the USB and it sees that and works well. It just stays plugged in to the USB and voila, wireless Carplay now, no need to ever plug the phone in. Maybe try that?
 

·
Registered
Challenger SRT Redeye
Joined
·
717 Posts
Discussion Starter · #5 ·
Thanks for the reply. I had said 2019 and older (really just looking for 2019) because the dealer is essentially saying my phone and software is too new and that’s why my UConnect/CarPlay/etc doesn’t recognize it.
 

·
Premium Member
2020 Challenger Hellcat Redeye Wide Body
Joined
·
10,247 Posts
Thanks for the reply. I had said 2019 and older (really just looking for 2019) because the dealer is essentially saying my phone and software is too new and that’s why my UConnect/CarPlay/etc doesn’t recognize it.
I'm aware of the 2019 and older intention that you meant. My comment was addressing that. The ECU was changed after 2018 and so what you were asking for may or may not be relevant because of the different software used before 2019. Your phone and software are not too new, trust me. You and I have the same set up (2019/2020), I'm unaware of any Uconnect updates/changes in 2020. My 2021 iphone 12 Pro Max with the newest ios update and software plays nice. Yours should too. I'm confident that your dealer is wrong and that they just don't know. The very fact that it was working fine before tells me that they are clearly wrong.
 

·
Registered
Challenger SRT Redeye
Joined
·
717 Posts
Discussion Starter · #7 ·
I'm aware of the 2019 and older intention that you meant. My comment was addressing that. The ECU was changed after 2018 and so what you were asking for may or may not be relevant because of the different software used before 2019. Your phone and software are not too new, trust me. You and I have the same set up (2019/2020), I'm unaware of any Uconnect updates/changes in 2020. My 2021 iphone 12 Pro Max with the newest ios update and software plays nice. Yours should too. I'm confident that your dealer is wrong and that they just don't know. The very fact that it was working fine before tells me that they are clearly wrong.
Thanks! I’ll edit my post.

Ok hopefully Dodge, or someone who knows, will jump in and confirm that the OS is the same in 19 and 20.

Oh it does me too. It’s like they just don’t want to be bothered with it. I knew they were going to try and blame me when I got a phone call asking what phone I had, what the software was, etc.
 
  • Like
Reactions: Slowpoke387

·
Registered
Challenger SRT 392
Joined
·
1,756 Posts
2019, Iphone 11 and 12 work fine
 

·
Registered
Challenger SRT Redeye
Joined
·
717 Posts
Discussion Starter · #9 ·

·
Registered
Challenger SRT 392
Joined
·
1,756 Posts
thanks! Assuming you are running the latest software?
I didnt think about that. In Phones yes. However not sure on the Uconnect. I never had the recall for the rear camera done so maybe not? Unsure if there is anything in the update that affects the carplay.
 

·
Registered
Challenger SRT Redeye
Joined
·
717 Posts
Discussion Starter · #11 ·
I didnt think about that. In Phones yes. However not sure on the Uconnect. I never had the recall for the rear camera done so maybe not? Unsure if there is anything in the update that affects the carplay.
thanks! Yes I was talking about the phones. My car has never been in for any kind of UConnect update either.
 

·
Premium Member
2020 Challenger Hellcat Redeye Wide Body
Joined
·
10,247 Posts
It's not your phone. A setting perhaps but not the software itself. Maybe check your Carplay settings on your phone if you havent already. Sometimes they get changed accidentally along the way while perusing other things on the phone.
 

·
Registered
Challenger SRT Redeye
Joined
·
717 Posts
Discussion Starter · #14 ·

·
Registered
Challenger SRT Redeye
Joined
·
717 Posts
Discussion Starter · #15 ·
It's not your phone. A setting perhaps but not the software itself. Maybe check your Carplay settings on your phone if you havent already. Sometimes they get changed accidentally along the way while perusing other things on the phone.
when I’m in the car trying to sync it this is what is displayed in settings. The system is not showing my car as an available car.
Jaw Font Slope Elbow Gesture
Jaw Font Slope Elbow Gesture
 

·
Registered
Charger SRT 392
Joined
·
7 Posts
Dealer is misdiagnosing saying it's your phone/iOS version. As someone else has said it's probably a setting. Don't just check the iPhone settings but also make sure in the UConnect settings that "Smartphone Projection" is turned on.

----

For my work I change phones quite often. I also almost always have a phone with the latest beta as well.

Currently iPhone 13 Pro Max with iOS 15.1 Beta and no problems on UConnect with my 2019 Charger Scat Pack. I have had no problems at any point over dozens of phones since getting the car. At one point I was using an iPhone SE with iOS 14-something and had no issues.
 

·
Registered
Challenger SRT 392
Joined
·
1,756 Posts
Assuming OEM Apple cord? youve tried both USB ports?
 

·
Registered
Charger SRT Hellcat
Joined
·
643 Posts
Always start troubleshooting at physical items

Have you tried a different cable?
 

·
Registered
Charger SRT 392
Joined
·
430 Posts
@DodgeCares

Car is at the dealership. 2019 Redeye….phone is an IPhone SE

Everything worked fine up until a few months ago. Then out of the blue the CarPlay stopped working. In addition when I have it plugged into the USB port it says “device not recognized”. Before it went to the dealer I did everything shown online to fix the issues. I then spent about an hour and a half on the phone with UConnect doing essentially the same thing again.

So I get an email today saying essentially my phone and software are too new and the system won’t recognize (doesn’t surprise me dealer is trying to blame me or something I did). I told them there’s no way that’s the case. If it was I’m sure I wouldn’t be the ONLY one with this issue.

So if you have a model year 2019 car and an IPhone I’d appreciate it if you’d post in here with your model car, model IPhone, and what software your phone currently has. I’m at my wits end with this and the dealership.
Something very similar happened to my business partner with his 2019 Challenger. We started by trying 2 other Apple cables and then used the other USB port (same result). Heck, we even reset his iPhone, wiped all phones from Uconnect, but nothing worked. Then we connected his iPhone to my Charger (2017) and CarPlay fired right up with no issue…worked perfectly.

Go back to the dealer, find another vehicle with Uconnect and see if it runs CarPlay. If it does, then it’s not your phone…and find a newer dealership if they are too dumb to understand how to correctly diagnose the problem.
 

·
Registered
Challenger SRT Redeye
Joined
·
717 Posts
Discussion Starter · #20 ·
Dealer is misdiagnosing saying it's your phone/iOS version. As someone else has said it's probably a setting. Don't just check the iPhone settings but also make sure in the UConnect settings that "Smartphone Projection" is turned on.

----

For my work I change phones quite often. I also almost always have a phone with the latest beta as well.

Currently iPhone 13 Pro Max with iOS 15.1 Beta and no problems on UConnect with my 2019 Charger Scat Pack. I have had no problems at any point over dozens of phones since getting the car. At one point I was using an iPhone SE with iOS 14-something and had no issues.
thanks for the reply.

I mean I guess it could be settings in UConnect but it still would mean there’s a glitch in the system as I did not change anything.
 
1 - 20 of 29 Posts
Top