SRT Hellcat Forum banner

1 - 10 of 10 Posts

·
Registered
Challenger SRT Hellcat
Joined
·
4 Posts
Discussion Starter #1
I updated to the latest version of Uconnect on my 2018 Hellcat a while ago and the bottom row of buttons stop responding to my taps if I have been driving for a bit, park the car for five-10 minutes and then start it back up.

This is incredibly annoying because to fix it, I have to turn the car back off, open my door to kill the power, then turn it back on. It happens every time I stop for a few minutes somewhere (for example, to grab a coffee then get back on the road). Alternatively, if the car has been sitting for an hour or more, I won't have any issues. I've tried all the reset methods posted around other places but none of those seem to work.

Anyone else encountered this??
 

·
Registered
2020 Challenger Hellcat Redeye Wide Body
Joined
·
9,075 Posts
Normally you just have to wait. Functions are usually slow to come back. Annoying but normally they all slowly do come back after an update. Odd that you can get it to work at different times though...
Give it a few days and if it doesnt come back correctly you need the stealer service dept. Ugh.
 

·
Registered
Challenger Widebody SRT Hellcat
Joined
·
11 Posts
I'm having a similar problem on my '18. Except it will happen in mid drive. If I'm driving for a while, I wont be able to tap on anything, like the screen is locked. Turn off and back on and it's back to normal. It's only happened like 2-3 times in the last month so I don't know how to make it happen on demand.
 

·
Registered
Challenger SRT Hellcat Widebody
Joined
·
959 Posts
It happens to my 2018 as well from time to time. I'm not recommending this but if I push the clutch in and coast I can hold the ignotion button in for 2 seconds and the engine stops running, then quickly restart engine and you're good. Power steering and brakes keep working during this process so not too crazy dangerous. I only attempt this if I'm on the freeway in the slow lane and pulling over to reset it is not an option when I need my A/C to operate.
 

·
Registered
Challenger SRT Hellcat Widebody
Joined
·
121 Posts
my 2018 is glitchy as well. usually have to turn the power off and on for the radio to respond to commands.
 

·
Registered
Charger SRT Hellcat
Joined
·
1,201 Posts
Yep, same issue here as my bottom row locks up usually every 2nd or 3rd startup. Restarting the car always recovers it. The dealer is going to replace the head unit whenever they can get a solid date from the factory on delivery.
 

·
FCA Official
Challenger SRT Hellcat
Joined
·
236 Posts
I updated to the latest version of Uconnect on my 2018 Hellcat a while ago and the bottom row of buttons stop responding to my taps if I have been driving for a bit, park the car for five-10 minutes and then start it back up.

This is incredibly annoying because to fix it, I have to turn the car back off, open my door to kill the power, then turn it back on. It happens every time I stop for a few minutes somewhere (for example, to grab a coffee then get back on the road). Alternatively, if the car has been sitting for an hour or more, I won't have any issues. I've tried all the reset methods posted around other places but none of those seem to work.

Anyone else encountered this??
I'm having a similar problem on my '18. Except it will happen in mid drive. If I'm driving for a while, I wont be able to tap on anything, like the screen is locked. Turn off and back on and it's back to normal. It's only happened like 2-3 times in the last month so I don't know how to make it happen on demand.
my 2018 is glitchy as well. usually have to turn the power off and on for the radio to respond to commands.
Yep, same issue here as my bottom row locks up usually every 2nd or 3rd startup. Restarting the car always recovers it. The dealer is going to replace the head unit whenever they can get a solid date from the factory on delivery.
Hi, I'm sorry to hear this. Please let me know if you plan on visiting a dealership for this concern. I would be happy to open a case for you.

Alison
DodgeCares
 

·
Registered
Challenger SRT 392
Joined
·
625 Posts
I’ve had my uConnect screen freeze on me, the backup camera does not operate, and iConnect system reboots like when you turn the car on. I have a 2018 SRT392. I’ve been reading that there are a lot of issues with the 2018 uConnect systems due to the addition of Screen Mirroring (via Apple CarPlay and Android Auto). I play music off Amazon Prime Music. When the system decides to reboot itself I notice the music playing off my iPhone sounding like it’s getting more and more staticky like I’m driving through a tunnel listening to broadcast FM radio until the reboot.

I tried doing a reset by disconnectingthe battery and waiting 10 min before reconnecting it. This solved the issue for 1 day and the problems returned.

I called the dealer to schedule a service visit. They mentioned there’s a uConnect update coming in 1Q 2021 (Jan-Mar some time). I am still keeping my appointment. I have heard several people had to have their iConnect head units replaced.
 

·
Registered
2020 Challenger Hellraisin Scat Pack.
Joined
·
2,193 Posts
I’ve had my uConnect screen freeze on me, the backup camera does not operate, and iConnect system reboots like when you turn the car on. I have a 2018 SRT392. I’ve been reading that there are a lot of issues with the 2018 uConnect systems due to the addition of Screen Mirroring (via Apple CarPlay and Android Auto). I play music off Amazon Prime Music. When the system decides to reboot itself I notice the music playing off my iPhone sounding like it’s getting more and more staticky like I’m driving through a tunnel listening to broadcast FM radio until the reboot.

I tried doing a reset by disconnectingthe battery and waiting 10 min before reconnecting it. This solved the issue for 1 day and the problems returned.

I called the dealer to schedule a service visit. They mentioned there’s a uConnect update coming in 1Q 2021 (Jan-Mar some time). I am still keeping my appointment. I have heard several people had to have their iConnect head units replaced.
The NAV system in my 2018 Hellcat went bad. Had me 40 miles from my actual location. Took the car in and tech confirmed NAV bad. After talking to Chrysler he downloaded two updates -- not yet released to uConnect site -- and first one then the other. Neither helped.

Tech removed the bezel and got some numbers from the radio and ordered a replacement. (This last July.) Replacement arrived in a week or so and had it installed. After NAV worked fine.
 
1 - 10 of 10 Posts
Top