SRT Hellcat Forum banner
  • Hey Everyone! Vote for the Site Favourite HOTM winner for the year of 2022 HERE!

UConnect Stuck in a Restart Loop?

4097 Views 16 Replies 5 Participants Last post by  Joe308
Hey everyone,

New member here. I’ve been having an issue with the Uconnect infotainment system on my ‘21 Redeye Widebody: while I was driving the screen went blank, turned off and then the system restarted. Then it kept doing it, and it still keeps doing it. It even does it when the car is off, every 1 to 5 minutes, which makes me worried that if I leave the car off for more than one night, I’ll find it with a depleted battery… I’ve already tried disconnecting the battery to have the car reset, but that didn’t help. Has anyone had a similar issue? Anyone heard of a fix? Thanks
1 - 4 of 17 Posts
Couple of things to try:

Ignition in the Run position, engine off, go into the Radio Menu and do a Factory Reset. Button Off & wait 60 seconds. Button in Run position, engine off again, do the Factory Reset again. Button Off. See if this fixes the issue.

If not, pull Fuse F37 (Radio Fuse) from the Fuse Panel next to the battery. Wait 60 seconds and plug back in. Make sure it's Fuse F37 Socket the fuse goes in when plugging back in.
  • Like
Reactions: 1
Thanks for the input. I tried the factory reset but it seems like it won’t let me do that(?).. the menu disappears the moment I press.

I tried checking the fuse box, but the diagram under the lid shows that F37 is the Engine Controller Fuse… am I looking at the wrong fuse panel?
Look for Radio Fuse...
I've tried just about everything, pulled amp radio and usb hub fuses let car sit overnight, etc and still no luck. It appears to be in some kind of a subscription update loop but won't stay on long enough to allow me to do anything. The NAV map screen tries to load but never does so I can't try the navigate trick to stop the reboots and the factory reset option is missing from the dealer mode menu. Not sure if there was a procedure problem, bad instructions from Dodge or an incompatibility the software cannot deal with but it's shot at this point. I'd love to get my hands on the 16.12 zip file and try to load it myself but the uconnect site tells me my software is up to date and I can't find it published anywhere. Dealer ordered a replacement radio which will be a refirb, not thrilled about that but fingers crossed it's a good one. Supposedly it will have the latest software on it already, hopefully it won't be missing the air intake temp gauge that some owners have reported.
If you can get the radio settings menu with the button in the Run Position, try a Factory Reset. If successful, cycle the button to Off & then Run again & do a 2nd Factory Reset...
Not seeing factory reset. Are you referring to settings gear menu or dealer mode menu? I tried reset personal settings but it didn't do full reset, just reverted changes I had made like EQ settings etc while station presets remained. I found a link to a 16.8 download on a Jeep owner's site but need the 16.12 the tsb was reccomending. If anyone knows a site please post. Hard to believe this is truly irreversible, I'm sure when my core is sent back after dealer replaces it the radio the factory will do a reset on it. Thanks again for any info.
Should be on the Settings Menu. Make sure to scroll down the list.

At some point, you'll want to get it to the dealer.
1 - 4 of 17 Posts