SRT Hellcat Forum banner
  • Hey Everyone! Vote for the Site Favourite HOTM winner for the year of 2022 HERE!
1 - 20 of 23 Posts

· Registered
Charger SRT Hellcat
Joined
·
270 Posts
Discussion Starter · #1 ·
It looks like a software update became available 3/26. It's UCONNECT® 8.4AN_RA4_15.06.1_MY15. Has anyone installed it yet? Any list of what's new?
 

· Thread Killer
Charger SRT Hellcat
Joined
·
2,111 Posts
from TSB 08-031-15 published 03-26-15
** denotes updates from TSB 08-079-14C published 12-23-14


SYMPTOM/CONDITION:


A small number of customers may experience one or more of the following:

· **Enable High Definition (HD) feature, (RA4 radios located in Canada and Mexico).**

· **Keyboard improvements, in the Points Of Interest (POI) section.**

· Low battery condition due to the radio remaining powered up after the ignition has


been turned off (U.S Markets Only).

· The Radio may switch from SiriusXM to an AM station by itself.

· Uconnect registration always present, can not remove Uconnect account.

· Teleprompter does not appear when pressing the Voice Recognition (VR) button.

· VR operation cancels while in media mode.

· Radio may display previous cameras image before displaying the current image.

· Navigation lost vehicle position, during route calculation.

· Navigation displays are missing after vehicle heading changes.

· Navigation giving incorrect guidance to exit the highway.

· FM audio may switch to AM after ignition cycle.

· Text messages appear as sender’s phone number not their name.

· VR phone button may not work at times.

· Audio muted after AUX device is disconnected.

· VR, “ Listen” to text, will only play 1st message.

· Drive Mode: Eco, sport or normal setting may not be saved after key cycle (LA, LD,


LX and ZD Only).

· Drive Mode: Shift light On/Off, out of sync (LA, LD, LX and ZD Only).

· SirusXM station information does not update.

· Speed adjusted volume, may not work.

· AM or FM seek or tuner soft keys may be missing.

· Display screen show ambient temperature as ”- - “ not normal values.


Improvements:

· High Definition (HD) radio buffering.

· Spanish translation.

· Radio station, scroll feature.

· Drive Mode: Launch control button, text improvements (LA, LD, LX and ZD Only).

· Making assist calls.

· App functionality and screen displays.

· Displays correct media, song titles and tracks.

· Travel Link, Points Of Interest (POI), displaying movies and favorites.

· Incoming calls, audio enhancements (LA, LD and LX Only).

· Audio for strong AM stations.

· VR performance.

· Settings can only be changed in run mode, not ACC.

· Notify user when messaging features are not supported on certain phones/devices.

· Shows direction and distance for POI when using VR
 

· Registered
Charger SRT Hellcat
Joined
·
270 Posts
Discussion Starter · #3 ·
So I had a problem installing this update and I wanted to share how I fixed it. The file that originally downloaded from the web site was called MY15_RA4_15_06_1_NAFTA.exe. When I ran it to extract the file for the update, it created MY15_RA4_15_06_1_NAFTA.iso on the USB stick. I made sure it was the only file on the USB stick and inserted it in the car, but the system didn't recognize it as an update file.

After doing a little research I saw that in the past the ISO files were named "swdl.iso" so I renamed the ISO file on the USB stick to swdl.iso. The system did recognize that as a valid update, and updated the system to version 15.06.1.

So if anyone else gets hit with this, make sure that the update file is named swdl.iso. Hopefully Chrysler will catch this soon and update the file on their servers so it'll just work without having to be manually renamed.
 

· Premium Member
Challenger SRT Hellcat
Joined
·
12,103 Posts
Yeah my last usb flash drive had swdl.iso and UConnect confirmed the Akamai installer did not extract the file correctly
 

· Premium Member
Challenger SRT Hellcat
Joined
·
12,103 Posts
I downloaded this on my mac, expanded the .zip file and it correctly placed the "swdl.iso" in a folder , which I copied to the flash drive. Have not updated yet and will tonight or tomorrow.
make sure to copy the file only to the flash drive no folders and no other files.
 

· Premium Member
Challenger SRT Hellcat
Joined
·
1,536 Posts
make sure to copy the file only to the flash drive no folders and no other files.
This does not matter. I've done the prior updates numerous times with other files in the drive. As long as it is on the ROOT of the drive and named swdl.iso, the radio will pick it up.

You beat me to the punch on providing a direct download. But you only have RA4 up and I have RA3. I'll still do my direct downloads for RA3 and RA4 with instructions later (can't do it at work).
 

· Premium Member
Challenger SRT Hellcat
Joined
·
12,103 Posts
This does not matter. I've done the prior updates numerous times with other files in the drive. As long as it is on the ROOT of the drive and named swdl.iso, the radio will pick it up.

You beat me to the punch on providing a direct download. But you only have RA4 up and I have RA3. I'll still do my direct downloads for RA3 and RA4 with instructions later (can't do it at work).
yeah i'm only reiterating what UConnect tells me every time. As far as RA3 or RA4 that's Charger and Challenger? If so i need to update the sticky accordingly. I only have access to RA4 as of this time using my VIN. If you'd like you can edit my sticky OP with your links as well.
 

· <Insert witty title here>
Charger SRT Hellcat
Joined
·
554 Posts
Just finished installing the update. First 5 minute impression...HUGE improvement.

1. Streaming Spotify from phone via Bluetooth - Before the update, changing songs on the steering wheel, perhaps, there was a sizeable lag/delay; not any more. Very quick. Sound quality seems to be the same, which was good before the update.
2. FM/SXM - Before the update, simply awful. SXM was 'tinny/shallow'. Definitely an improvement in the mids- and highs. The subwoofer doesn't hit as hard as media sources, but another improvement.

In my brief assessment, I'm impressed. If Ralph Gilles was closer, I'd hug him.

Post your thoughts when you completed your update!
 

· Premium Member
Challenger SRT Hellcat
Joined
·
8,160 Posts
I just updated my radio but i seemed to have lost my access to the performance page/srt drive mode feature on the radio. I keep getting the message "renew your uconnect subscription". What is going on? Please help!!:eek::confused:
 

· Premium Member
Challenger SRT Hellcat
Joined
·
8,160 Posts
I finally managed to get a hold of uconnect customer service and they asked me to start it up again and it worked. The changes are apparently applied when you restart the system. Secondly i have noticed some difference in the music quality and the lows now appear to be more pronounced and deep. However the car display or graphic on the SRT/Performance page has changed to a default silver color. I had my car display in Red corresponding to the color of my car and it looked visually pleasing, however the update has resulted in me losing that feature. There is no way to change the color of the car display on the screen....the uconnect agent i spoke with had no clue and said that there was no workaround available to rectify/change that feature. Someone with a more in-depth knowledge of the radio functionality might like to chime in!!!
 

· Registered
Challenger SRT Hellcat
Joined
·
905 Posts
Sure hope this update works! Stereo sounds terrible! (mostly listen to SXM)

You know it's bad when you'd prefer to put a boom box on the seat next to you for improved hi fidelity sound. :confused:
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top